Bug 1474520 - WebUI Service Catalog: Create Binding is spinning, WebUI doesn't reflect operation has completed.
WebUI Service Catalog: Create Binding is spinning, WebUI doesn't reflect ope...
Status: CLOSED DUPLICATE of bug 1472148
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Samuel Padgett
XiaochuanWang
:
Depends On: 1472148
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 16:37 EDT by John Matthews
Modified: 2017-07-24 16:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 16:41:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2017-07-24 16:37:17 EDT
Description of problem:

In the WebUI we are seeing that "Create Binding" is working, but the WebUI modal window does not reflect the binding has completed.  The spinner stays up.

We are seeing "Server Connection Interrupted", which we think is related to:
 https://bugzilla.redhat.com/show_bug.cgi?id=1472148

Likely this BZ is another manifestation of BZ 1472148, filing this so we can track in case it's something different.

Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift
python2-openshift-1.0.0-0.3.el7.noarch
openshift-ansible-docs-3.6.162-1.git.0.50e29bd.el7.noarch
openshift-ansible-lookup-plugins-3.6.162-1.git.0.50e29bd.el7.noarch
atomic-openshift-clients-3.6.153-1.git.0.4894417.el7.x86_64
atomic-openshift-sdn-ovs-3.6.153-1.git.0.4894417.el7.x86_64
openshift-ansible-3.6.162-1.git.0.50e29bd.el7.noarch
openshift-ansible-filter-plugins-3.6.162-1.git.0.50e29bd.el7.noarch
openshift-ansible-roles-3.6.162-1.git.0.50e29bd.el7.noarch
atomic-openshift-excluder-3.6.153-1.git.0.4894417.el7.noarch
atomic-openshift-3.6.153-1.git.0.4894417.el7.x86_64
atomic-openshift-node-3.6.153-1.git.0.4894417.el7.x86_64
openshift-ansible-callback-plugins-3.6.162-1.git.0.50e29bd.el7.noarch
openshift-ansible-playbooks-3.6.162-1.git.0.50e29bd.el7.noarch
atomic-openshift-docker-excluder-3.6.153-1.git.0.4894417.el7.noarch
atomic-openshift-master-3.6.153-1.git.0.4894417.el7.x86_64
tuned-profiles-atomic-openshift-node-3.6.153-1.git.0.4894417.el7.x86_64


How reproducible:
Seems to be on each attempt with latest puddles.

Steps to Reproduce:
1. Install with openshift-ansible
2. Enable Service Catalog and Ansible Service Broker
3. Provision Mediawiki APB and PostgreSQL APB
4. Click 'Create Binding' on Mediawiki

Actual results:
Modal window stays up with spinner waiting for Create Binding to complete

Expected results:
See window update that create binding has completed, as we observe with oc cluster up

Additional info:
Comment 1 Samuel Padgett 2017-07-24 16:41:04 EDT
Hey, John. We rely on the websocket to get status updates on the binding to tell us its ready. The "Server Connection Interrupted" message happens when the websocket closes abnormally. So your suspicion that it's due to BZ 1472148 seems right.

I'm going to mark it a duplicate. Appreciate the heads up.

*** This bug has been marked as a duplicate of bug 1472148 ***

Note You need to log in before you can comment on or make changes to this bug.