Bug 1474692 - Remove unsupported parameters from glusterfs example inventory files
Summary: Remove unsupported parameters from glusterfs example inventory files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.6.z
Assignee: Jose A. Rivera
QA Contact: Wenkai Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-25 07:30 UTC by Wenkai Shi
Modified: 2017-12-14 21:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cleanup example inventory files for GlusterFS.
Clone Of:
Environment:
Last Closed: 2017-12-14 21:01:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3438 normal SHIPPED_LIVE OpenShift Container Platform 3.6 and 3.5 bug fix and enhancement update 2017-12-15 01:58:11 UTC

Description Wenkai Shi 2017-07-25 07:30:58 UTC
Description of problem:
There are some unsupported parameter in glusterfs example inventory files, suggest to remove them. In case it mislead the customer.

Version-Release number of the following components:
openshift-ansible-docs-3.6.169-1.git.0.440d532.el7

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
# grep -nir -e "node=True" -e "storage=True" -e "master=True" /usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.external.example:34:master  node=True storage=True master=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.external.example:37:master  node=True storage=True master=True openshift_schedulable=False
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.external.example:38:node0   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.external.example:39:node1   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.external.example:40:node2   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.mixed.example:37:master  node=True storage=True master=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.mixed.example:40:master  node=True storage=True master=True openshift_schedulable=False
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.mixed.example:41:node0   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.mixed.example:42:node1   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.mixed.example:43:node2   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.native.example:27:master  node=True storage=True master=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.native.example:30:master  node=True storage=True master=True openshift_schedulable=False
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.native.example:33:node0   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.native.example:34:node1   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.native.example:35:node2   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.registry-only.example:33:master  node=True storage=True master=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.registry-only.example:36:master  node=True storage=True master=True openshift_schedulable=False
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.registry-only.example:39:node0   node=True openshift_node_labels="{'region': 'infra'}" openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.registry-only.example:40:node1   node=True openshift_node_labels="{'region': 'infra'}" openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.registry-only.example:41:node2   node=True openshift_node_labels="{'region': 'infra'}" openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.storage-and-registry.example:34:master  node=True storage=True master=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.storage-and-registry.example:37:master  node=True storage=True master=True openshift_schedulable=False
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.storage-and-registry.example:40:node0   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.storage-and-registry.example:41:node1   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.storage-and-registry.example:42:node2   node=True openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.storage-and-registry.example:45:node3   node=True openshift_node_labels="{'region': 'infra'}" openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.storage-and-registry.example:46:node4   node=True openshift_node_labels="{'region': 'infra'}" openshift_schedulable=True
/usr/share/doc/openshift-ansible-docs-3.6.169/docs/example-inventories/hosts.byo.glusterfs.storage-and-registry.example:47:node5   node=True openshift_node_labels="{'region': 'infra'}" openshift_schedulable=True


Expected results:
Suggest to remove those parameters.

Additional info:

Comment 1 Jose A. Rivera 2017-07-25 12:59:41 UTC
Fix is upstream: https://github.com/openshift/openshift-ansible/pull/4859

Comment 2 Jose A. Rivera 2017-07-25 13:19:37 UTC
PR is merged.

Comment 3 Wenkai Shi 2017-07-26 10:03:56 UTC
Verified with version openshift-ansible-docs-3.6.171-1.git.0.9d04eee.el7, parameters removed.

# grep -nir -e "node=True" -e "storage=True" -e "master=True" /usr/share/doc/openshift-ansible-docs-3.6.171/docs/example-inventories/

Comment 7 errata-xmlrpc 2017-12-14 21:01:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3438


Note You need to log in before you can comment on or make changes to this bug.