Bug 1474714 - Unable to install newton + contrail
Unable to install newton + contrail
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Or Idgar
Arik Chernetsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 04:57 EDT by Eduard Barrera
Modified: 2017-10-03 09:56 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-03 09:56:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1417754 None None None 2017-07-25 04:59 EDT
Red Hat Bugzilla 1459468 None None None 2017-07-25 05:00 EDT
Red Hat Bugzilla 1472305 None None None 2017-07-25 04:57 EDT

  None (edit)
Description Eduard Barrera 2017-07-25 04:57:51 EDT
Description of problem:

Some help is required here to find what customer is doing wronng installing openstack 10 + contrail, there should be a common root cause for all issues customer is having. I tried to install osp 10 + contrail but didn't have issues.



Case already ongoing for 2 months.

Customer is deploying 1 controller , 1 contrail controller , 1 contrail analytics , 1 contrail analytics DB , 1 compute node.

# openstack overcloud deploy --templates tripleo-heat-templates/ --roles-file tripleo-heat-templates/environments/contrail/roles_data.yaml -e tripleo-heat-templates/extraconfig/pre_deploy/rhel-registration/environment-rhel-registration.yaml -e tripleo-heat-templates/extraconfig/pre_deploy/rhel-registration/rhel-registration-resource-registry.yaml -e tripleo-heat-templates/environments/contrail/contrail-services.yaml -e tripleo-heat-templates/environments/contrail/contrail-net-single.yaml



We found many issues:
1.- yum Multilib version problems found yum -d 0 -e 0 -y install contrail-openstack-analytics (contrail specific ? )
Bguzilla pending, attached kcs didn't help

2.- Error: /Stage[main]/Aodh::Db::Sync/Exec[aodh-db-sync]: Could not find command 'aodh-dbsync'^[[0m
Aparently openstack-aodh-api is not installed, https://bugzilla.redhat.com/1472305 (redhat specific ? )

3.- Compute node can't get registered - https://bugzilla.redhat.com/1417754 ( redhat specific )

4.- vhost0 insterface not found ( Contrail specific ) http://post-office.corp.redhat.com/archives/rhos-tech/2017-July/msg00107.html , maybe related to 3 for missing dependences. Not sure how customer workarounded it... 




-------
Questions for rhos-tech thread:http://post-office.corp.redhat.com/archives/rhos-tech/2017-July/msg00108.html

1.- Did you found any of these issues ?
2.- About the vhost issue, should be there any specific module installed ? I'm asking because I find none in customer sosreport.



/cases/01862808/sosreport-20170714-194534/overcloud-novacompute-0.localdomain/var/log/messages

Jul 14 19:10:37 host-192-0-2-18 cloud-init: ./lib/modules/3.10.0-229.el7.x86_64/extra/net/vrouter/vrouter.ko
Jul 14 19:10:38 host-192-0-2-18 cloud-init: ./lib/modules/3.10.0-327.10.1.el7.x86_64/extra/net/vrouter/vrouter.ko
Jul 14 19:10:38 host-192-0-2-18 cloud-init: 52987 blocks
Jul 14 19:10:38 host-192-0-2-18 kernel: vrouter: loading out-of-tree module taints kernel.
Jul 14 19:10:38 host-192-0-2-18 kernel: vrouter: module verification failed: signature and/or required key missing - tainting kernel
Jul 14 19:10:38 host-192-0-2-18 kernel: vrouter version: {"build-info": [{"build-time": "2017-05-01 01:45:24.153686", "build-hostname": "contrail-builder-R3_2-redhat70-10-84-35-155", "build-user": "contrail-builder", "build-version": "3.2.3.0"}]}

but I dont see that modules on lsmod. Is this normal ?


3.- About the mojo documentation, could it be possible to add some information about vhost0 interface and how it should be configured / required kernel modules ? It's to avoid further support cases like the one I'm involved.



------------

More details on each issue:

1.- linked to the case there is a kcs about multilib that didn't work, customer uninstalled the already installed snmp packages

Error: Could not update: Execution of '/usr/bin/yum -d 0 -e 0 -y install contrail-openstack-analytics' returned 1: Error:  Multilib version problems found. This often means that the root
           cause is something else and multilib version checking is just
           pointing out that there is a problem. Eg.:
           
             1. You have an upgrade for net-snmp-libs which is missing some
                dependency that another package requires. Yum is trying to
                solve this by installing an older version of net-snmp-libs of the
                different architecture. If you exclude the bad architecture
                yum will tell you what the root cause is (which package
                requires what). You can try redoing the upgrade with
                --exclude net-snmp-libs.otherarch ... this should give you an error
                message showing the root cause of the problem.
           
             2. You have multiple architectures of net-snmp-libs installed, but
                yum can only see an upgrade for one of those architectures.
                If you don't want/need both architectures anymore then you
                can remove the one with the missing update and everything
                will work.
           
             3. You have duplicate versions of net-snmp-libs installed already.
                You can use "yum check" to get yum show these errors.
           
           ...you can also use --setopt=protected_multilib=false to remove
           this checking, however this is almost never the correct thing to
           do as something else is very likely to go wrong (often causing
           much more problems).
           
           Protected multilib versions: 1:net-snmp-libs-5.7.2-24.el7_2.1.i686 != 1:net-snmp-libs-5.7.2-24.el7_3.2.x86_64
    Error: /Stage[main]/Contrail::Analytics::Install/Package[contrail-openstack-analytics]/ensure: change from absent to latest failed: Could not update: Execution of '/usr/bin/yum -d 0 -e 0 -y install contrail-openstack-analytics' returned 1: Error:  Multilib version problems found. This often means that the root



2.- not much to add there are opened bugs downstream and upstream

3.- 
extracted from bugzilla: For example, a deployment with 11 total overcloud nodes (3 controller nodes, 5 compute nodes and 3 Ceph OSD nodes) would require 11 OSP subscriptions and 11 Ceph OSD subscriptions (the undercloud should require only 1 OSP subscription and no Ceph subscription).

https://bugzilla.redhat.com/1417754

4.- Not sure how customer solved the issue, I asked but replyed with half of what I asked, for sure its a topic we will have to start again when instances can't reach internet or instances can we created bevcause neutron fails



Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Install osp 10 + contrail
2.
3.

Actual results:
all kind of errors

Expected results:
installed

Additional info:
Comment 4 Mike Orazi 2017-07-31 14:48:20 EDT
Guil,

Can you help look at the multilib/repo issue.
Comment 5 Mike Burns 2017-07-31 14:52:00 EDT
Eduard -- can you provide full yum output for the multilib/repo error?
Comment 14 Assaf Muller 2017-08-07 09:26:06 EDT
Assigned to Or for triage.
Comment 25 Ihar Hrachyshka 2017-10-03 09:56:05 EDT
Closing as NOTABUG because old RHEL bits were used.

Note You need to log in before you can comment on or make changes to this bug.