Bug 1474727 - Coloured root terminal prompt
Coloured root terminal prompt
Status: CLOSED DUPLICATE of bug 1228939
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Siteshwar Vashisht
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2017-07-25 05:26 EDT by Armin Wehrfritz
Modified: 2017-07-25 05:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-07-25 05:46:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
bash.bashrc openSUSE Leap 42.2 (8.94 KB, text/plain)
2017-07-25 05:26 EDT, Armin Wehrfritz
no flags Details

  None (edit)
Description Armin Wehrfritz 2017-07-25 05:26:49 EDT
Created attachment 1304116 [details]
bash.bashrc openSUSE Leap 42.2

This is a feature request for a coloured root terminal prompt.

I work a lot with the command line and find it very useful to have the prompt coloured in red and bold if I am working as root (this happens rarely, but if then the red colour reminds to be careful).

I recently switch from openSUSE to Fedora 26 and I am overall very happy with the decision. However, this is one of the very few features that I am missing.
I attached the system-wide (i.e. /etc/bash.bashrc) bashrc from openSUSE Leap 42.2, which contains the hacks they apply to get the root prompt in red and bold (see lines 165 ff.).
Comment 1 Armin Wehrfritz 2017-07-25 05:30:11 EDT
Oh, I forgot to add, there has been a rather old SUSE bug report where they discussed the various options on how to get this feature implemented.
Not sure if it is of any value, but here is the link:
Comment 2 Kamil Dudka 2017-07-25 05:32:33 EDT
This is a duplicate of bug #1228939.
Comment 3 Armin Wehrfritz 2017-07-25 05:46:11 EDT
Sorry for the duplicate report.

*** This bug has been marked as a duplicate of bug 1228939 ***

Note You need to log in before you can comment on or make changes to this bug.