Bug 1474740 - /etc/redhat-storage-release file containing the image name is missing in rhgs-block provisioner container image
/etc/redhat-storage-release file containing the image name is missing in rhgs...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhgs-gluster-block-prov-container (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity medium
: ---
: CNS 3.6
Assigned To: Mohamed Ashiq
Prasanth
:
Depends On:
Blocks: 1445448
  Show dependency treegraph
 
Reported: 2017-07-25 06:01 EDT by Humble Chirammal
Modified: 2017-10-11 02:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: The enhancement to is to mention the storage release file in the gluster block image. Reason: Adhering to the naming standards to have the /etc/redhat-storage-release. Result: The images now have the /etc/redhat-storage-release file mentioned.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-11 02:57:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Humble Chirammal 2017-07-25 06:01:38 EDT
Description of problem:

Description of problem:

/etc/redhat-storage-release file containing the image name is missing in the rhgs-block provisioner container image

#####
# oc rsh <gluster block provisioner>
sh-4.2# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.4 Beta (Maipo)
sh-4.2# cat /etc/redhat-storage-release
cat: /etc/redhat-storage-release: No such file or directory
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 5 Humble Chirammal 2017-07-25 06:10:24 EDT
The mentioned file will have below content :

Red Hat Gluster Storage Block Provisioner(Container)
Comment 9 Sudhir 2017-07-26 09:31:53 EDT
CNS is good. We intend to use that as an acronym for Container Native Storage. Let's start using it. Also, Prasanth mentioned that we use the version number in the name, not sure why but that has been the convention so far. 

If that is useful, please add. I am afraid folks may use the name to guess the version number which may not be the best way or accurate always to determine the version number.
Comment 10 Humble Chirammal 2017-08-30 06:57:02 EDT
Thanks Sudhir, Dev and QE also agree on this and we will have below entry in the same file 

Red Hat CNS Block Provisioner 3.3 (Container)
Comment 11 Prasanth 2017-09-13 05:13:57 EDT
(In reply to Humble Chirammal from comment #10)
> Thanks Sudhir, Dev and QE also agree on this and we will have below entry in
> the same file 
> 
> Red Hat CNS Block Provisioner 3.3 (Container)

Verified.

[root@dhcp46-186 ~]# oc rsh glusterblock-provisioner-dc-1-gtd8z
sh-4.2$ cat /etc/redhat-storage-release 
Red Hat CNS Block Provisioner 3.3 (Container)
Comment 13 errata-xmlrpc 2017-10-11 02:57:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2875

Note You need to log in before you can comment on or make changes to this bug.