Bug 1474772 - Latest ceph is not built on arm7
Latest ceph is not built on arm7
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ceph (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Boris Ranto
Fedora Extras Quality Assurance
: Reopened
Depends On: 1474743 1474773 1474774
Blocks: FE-ExcludeArch-x86/F-ExcludeArch-x86
  Show dependency treegraph
 
Reported: 2017-07-25 07:33 EDT by Kaleb KEITHLEY
Modified: 2017-07-29 06:24 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1474743
Environment:
Last Closed: 2017-07-29 06:24:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2017-07-25 07:33:06 EDT
+++ This bug was initially created as a clone of Bug #1474743 +++

Description of problem:
The latest update of Ceph in rawhide just excluded several Fedora architectures

 ExcludeArch:   i686 armv7hl ppc64

As a result this has broken downstream packages that depend on ceph like libvirt & QEMU.

Please re-enable these architectures asap.

If there are build problems then plesae create blocker bugs against the arch exclude trackers

https://fedoraproject.org/wiki/Packaging:Guidelines#Architecture_Build_Failures

Version-Release number of selected component (if applicable):
12.1.1-1

--- Additional comment from Kaleb KEITHLEY on 2017-07-25 07:22:38 EDT ---

It doesn't build on those platforms.

File a bug against Ceph.

--- Additional comment from Daniel Berrange on 2017-07-25 07:29:19 EDT ---

That's not the way Fedora works. As per the packaging guidelines link above, maintainers need to explicitly track any build problems on architectures & mark them as blocking the arch trackers so the problem can be resolved.
Comment 1 Kaleb KEITHLEY 2017-07-25 07:43:50 EDT
see build log at

https://koji.fedoraproject.org/koji/taskinfo?taskID=20683236
Comment 2 Daniel Berrange 2017-07-25 09:05:20 EDT
cmake is failing to find the Java JNI for some reason

CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
  Could NOT find JNI (missing: JAVA_AWT_LIBRARY)
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:377 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake/Modules/FindJNI.cmake:310 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  src/java/CMakeLists.txt:2 (find_package)


Since java is an optional feature of ceph, please at least try disabling java for arm7 as a temporary workaround to allow the main native libs to biuld.
Comment 3 Kaleb KEITHLEY 2017-07-25 13:58:13 EDT
Still fails: Out of memory.

https://koji.fedoraproject.org/koji/taskinfo?taskID=20724038
Comment 4 Kaleb KEITHLEY 2017-07-26 08:09:11 EDT
excerpt from https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/BOQEQGV6UODCMTDLQLKSS2I27NM7SD3Q/?sort=date

> The ARM builders (both ARMv7 and aarch64) have 24 Gb of memory, which is 
> more than all other arches which have 10Gb, so I suspect the issue is not
> in the build hardware but an issue with ceph itself using (or leaking) 
> too much memory. Peter
Comment 5 Boris Ranto 2017-07-26 09:08:39 EDT
AFAICR, we were hitting out of memory errors in the builds quite randomly even on other platforms (e.g. i686). I guess this might have more to do with the platforms being 32-bit, i.e. having 4G per process, than the overall amount of memory on the machines. Alternatively, this may have something to do with not enough disk space?

Does a rebuild help or is this reproducible always?
Comment 6 Kaleb KEITHLEY 2017-07-26 09:40:44 EDT
In a very small sample size (IOW not statistically valid) it seems to build reliably on i686.

atm I'm trying Björn Esser's suggestion to see if that helps.

> It looks like the whole parallelized make-process is hitting the 4 Gbytes
> limit per process / task on 32 Bit arches…
>
> Have you tried this?
>
> %build
> export CFLAGS="echo %{optflags} | sed -e 's!-pipe!!g'"
> export CXXFLAGS="$CFLAGS"
> …
>
> Sometimes piping from cpp to gcc to as to ld takes too much memory on 32 
> Bit arches…

Note You need to log in before you can comment on or make changes to this bug.