Bug 1474777 - Remove run-time dependency on rh-maven35
Remove run-time dependency on rh-maven35
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-mongodb34 (Show other bugs)
rh-mongodb34
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 3.0
Assigned To: Marek Skalický
Vaclav Danek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 07:44 EDT by Marek Skalický
Modified: 2017-10-24 05:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: rh-mongodb34-3.0-11.el6, rh-mongodb34-3.0-11.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-24 05:55:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3027 normal SHIPPED_LIVE new packages: rh-mongodb34 2017-10-24 09:36:01 EDT

  None (edit)
Description Marek Skalický 2017-07-25 07:44:39 EDT
Description of problem:
rh-mongodb34 needed rh-maven35 for run-time (rh-mongodb{32,26},... have similar dependency too). It was because mongo-java-driver in mongodb collection required some runtime dependencies from maven collection.

Actual results:
Now all runtime dependencies of rh-mongodb34-mongo-java-driver package are in rh-mongodb34 SCL, so automatic enabling of rh-maven35 in enable script of rh-mongodb34 is not needed.


Expected results:
No rh-maven35-runtime dependency of rh-mongodb34-runtime rpm
Comment 4 errata-xmlrpc 2017-10-24 05:55:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3027

Note You need to log in before you can comment on or make changes to this bug.