Bug 1474811 - A MiqAeServiceManageIQ_Providers_Kubernetes_ContainerManager_ContainerGroup object derives from the wrong class
A MiqAeServiceManageIQ_Providers_Kubernetes_ContainerManager_ContainerGroup o...
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.8.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.8.1
Assigned To: Greg McCullough
Tasos Papaioannou
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 08:31 EDT by Peter McGowan
Modified: 2017-08-24 12:51 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.8.1.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-24 12:51:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description Peter McGowan 2017-07-25 08:31:27 EDT
Description of problem:
A MiqAeServiceManageIQ_Providers_Kubernetes_ContainerManager_ContainerGroup object derives from MiqAeServiceProvider, whereas I suspect it should derive from MiqAeServiceContainerGroup (in the same way that the model ManageIQ::Providers::Kubernetes::ContainerManager::ContainerGroup derives from ::ContainerGroup)

This means that the associations of MiqAeServiceContainerGroup are not visible to a MiqAeServiceManageIQ_Providers_Kubernetes_ContainerManager_ContainerGroup object.

Version-Release number of selected component (if applicable):
5.8.0.17

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Greg McCullough 2017-07-25 09:12:43 EDT
This issue was reported as a comment in https://bugzilla.redhat.com/show_bug.cgi?id=1455563#c5 and fixed in PR https://github.com/ManageIQ/manageiq/pull/15235 on the Fine (CFME 5.8) branch.

I am moving the ticket to POST so it can be tested since the related BZ above does not clearly identify this issue as part of the title or description.

Also note that this is not an issue upstream (currently 5.9) where empty service models are auto-generated.
Comment 3 Tasos Papaioannou 2017-07-27 16:21:08 EDT
Verified on 5.8.1.5.

irb> MiqAeMethodService::MiqAeServiceManageIQ_Providers_Kubernetes_ContainerManager_ContainerGroup.superclass
=> MiqAeMethodService::MiqAeServiceContainerGroup

irb> MiqAeMethodService::MiqAeServiceManageIQ_Providers_Kubernetes_ContainerManager_ContainerGroup.all[0]
=> #<MiqAeServiceManageIQ_Providers_Kubernetes_ContainerManager_ContainerGroup:0x6324b54 @object=#<ManageIQ::Providers::Kubernetes::ContainerManager::ContainerGroup id: 7, ems_ref: "d9a426f0-4468-11e7-ac9d-001a4a3dca1f", name: "heapster-7iiqw", ems_created_on: "2017-05-29 12:17:57", resource_version: "5406397", <snip>>

irb> MiqAeMethodService::MiqAeServiceContainerGroup.all[0]
=> #<MiqAeServiceManageIQ_Providers_Kubernetes_ContainerManager_ContainerGroup:0x6317f58 @object=#<ManageIQ::Providers::Kubernetes::ContainerManager::ContainerGroup id: 7, ems_ref: "d9a426f0-4468-11e7-ac9d-001a4a3dca1f", name: "heapster-7iiqw", ems_created_on: "2017-05-29 12:17:57", resource_version: "5406397", <snip>>

Note You need to log in before you can comment on or make changes to this bug.