Bug 147483 - system-config-services errors "/etc/init.d/ [Errno 21] Is a directory"
system-config-services errors "/etc/init.d/ [Errno 21] Is a directory"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-08 09:09 EST by Lars G
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 16:44:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lars G 2005-02-08 09:09:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
with latest rawhide from today
system-config-services says:

/usr/sbin/system-config-services:197: DeprecationWarning:
  self.btnStart = self.tbrSave.append_item(_("Start"), _("Start"), None, icon, self.on_btnStart_clicked, None)
/usr/sbin/system-config-services:201: DeprecationWarning:
  self.btnStop = self.tbrSave.append_item(_("Stop"), _("Stop"), None, icon, self.on_btnStop_clicked, None)
/usr/sbin/system-config-services:205: DeprecationWarning:
  self.btnRestart = self.tbrSave.append_item(_("Restart"), _("Restart"), None, icon, self.on_btnRestart_clicked, None)
/usr/sbin/system-config-services:207: DeprecationWarning:
  self.tbrSave.insert_space(3)
/usr/sbin/system-config-services:211: DeprecationWarning:
  self.btnSave = self.tbrSave.append_item(_("_Save"), _("Save"), None, icon, self.on_mnuSave_clicked, None)
/usr/sbin/system-config-services:216: DeprecationWarning:
  self.btnRevert = self.tbrSave.append_item(_("_Revert"), _("Revert"), None, icon, self.on_mnuRevert_clicked, None)
/etc/init.d/ [Errno 21] Is a directory
/etc/xinetd.d/ [Errno 21] Is a directory

and then it exits.



Version-Release number of selected component (if applicable):
system-config-services-0.8.18-1

How reproducible:
Always

Steps to Reproduce:
- start system-config-services on console
- see error-message.


Additional info:
Comment 1 Clyde E. Kunkel 2005-02-14 13:36:46 EST
I am seeing the same error...
Comment 2 Nils Philippsen 2005-06-06 03:43:50 EDT
I still see this with system-config-services-0.8.25.
Comment 3 Fernando Fernandez Pedraza 2005-06-16 08:34:14 EDT
Same problem here with 0.8.25-1 - Fedora Core release 4 (Stentz)
Comment 4 Nils Philippsen 2005-06-16 08:38:39 EDT
0.8.25-1 is 0.8.25, only packaged ;-)
Comment 5 J.Jansen 2005-07-19 04:57:49 EDT
This bug causes that services which depend on xinetd (i.e. rsh and rlogin)
cannot be started/defined from the menus.
Comment 6 Todd Denniston 2005-11-15 12:54:10 EST
Should this bug's Version be changed to fc4, so that people looking for bugs in
the currently released product to fix will find it? 
as suggested for fc4 bugs at https://bugzilla.redhat.com/bugzilla/index.cgi 
Comment 7 Lars G 2005-11-28 16:44:32 EST
works for me on rawhide, so i'm closing this one.
Comment 8 Dave Huff 2006-09-04 06:07:31 EDT
Same Problem but system-config-services will not start at all

Note You need to log in before you can comment on or make changes to this bug.