Bug 1474841 - can't click on Custom submenu by Preview snapshot
can't click on Custom submenu by Preview snapshot
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Alexander Wels
samuel macko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 09:36 EDT by Lucie Leistnerova
Modified: 2017-12-20 06:04 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:04:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)
snapshot_preview (48.51 KB, image/png)
2017-07-25 09:36 EDT, Lucie Leistnerova
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80071 master MERGED webadmin: preview snapshot button 2017-08-01 14:58 EDT

  None (edit)
Description Lucie Leistnerova 2017-07-25 09:36:29 EDT
Created attachment 1304215 [details]
snapshot_preview

Description of problem:
In snapshot details clicking on Preview shows submenu 'Custom...' but immediately main snapshot dialog appears. So user can't reach the submenu.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170723141021.git463826a.el7.centos.noarch

How reproducible: always


Steps to Reproduce:
1. create snapshot of VM
2. go to VM details -> Snapshots tab
3. select the created snapshot and click Preview

Actual results: new dialog appears and user can't click on Custom, see attachment


Expected results: the dialog doesn't appear so fast and user has time to click on Custom or the button has two parts - one for snapshot main dialog and one for submenus
Comment 1 Michal Skrivanek 2017-07-26 02:16:25 EDT
Alex, can you take a look please?
Comment 2 Alexander Wels 2017-07-26 08:00:41 EDT
Looks like we are using the wrong button type, it needs to be a split button with the button part opening the dialog and the drop down part opening a drop down, should be an easy fix. This is similar to how the console split button in VMs works.
Comment 3 Tomas Jelinek 2017-08-01 06:23:38 EDT
ok, since the issue has been introduced during ui redesign and you know exactly how to fix it quickly, assigning to ux.
Comment 4 samuel macko 2017-08-31 11:02:42 EDT
Verified in ovirt version 4.2.0-0.0.master.20170828065003.git0619c76.el7.centos.

Verified by following the reproducer.
Comment 5 Sandro Bonazzola 2017-12-20 06:04:48 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.