Bug 1474870 - [Docs][Upgrade] Update Upgrade Guide to recommend VMs power cycle
[Docs][Upgrade] Update Upgrade Guide to recommend VMs power cycle
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
4.0.7
Unspecified Unspecified
urgent Severity urgent
: ovirt-4.1.5
: ---
Assigned To: Byron Gravenorst
Emma Heftman
: EasyFix, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 10:24 EDT by Jiri Belka
Modified: 2017-11-12 22:25 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-12 22:25:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2017-07-25 10:24:09 EDT
Description of problem:

we recommend to power cycle all VMs after changing cluster level soon.

but we do not have such info in Upgrade Guides[1][2].

Michal Skrivanek noted the power cycle in a thread with following
text:

~~~
note that for migration improvements to be effective (4.0 feature) the
cluster level would need to be further updated to 4.0 compatibility
and migration policy would need to be changed from “Legacy” then. This
4.0 cluster update need to happen only AFTER all the former originally
3.5 VMs are power cycled and running properly as 3.6 VMs! Otherwise
the same migration configuration tweaks may need to be applied (I
suppose it’s mainly the bandwidth speed, but pending confirmation)
~~~

Version-Release number of selected component (if applicable):
4.0/4.1
Comment 1 Jiri Belka 2017-07-25 10:26:35 EDT
Michal, could you prepare a text for this recommendation explaining
reasoning for this please?
Comment 2 Michal Skrivanek 2017-07-25 10:29:48 EDT
the text is in bug 1356027 doc text
Comment 3 Lucy Bopf 2017-07-28 04:33:57 EDT
Assigning to Byron for review.
Comment 7 Byron Gravenorst 2017-08-13 23:24:29 EDT
Implemented review comments and merged.
Comment 9 Igor Netkachev 2017-11-07 10:32:12 EST
Hello,

Reopening this one per customer's request because in sentence "This is achieved by restarting the virtual machine" the word 'restart' is oftem read by customers as 'reboot', and those are 2 different things: 'reboot' could be thought of as an event triggered from inside guest OS (hence the same qemu process is still running on hypervisor even though guest OS inside has been reinitialized), and 'restart' is an action initiated from GUI or REST API (and implies shutting down current qemu process and starting new one instead, so that new qemu process could pick up new functionality of the new DC/cluster level).

I would suggest to clarify term 'restart' in the above doc, e.g.:

"This is achieved by restarting the virtual machine (power-cycle, or cold restart, initiated via Manager UI or REST API call, in contrast to 'warm reboot' initiated from within guest operating system)"

Please let me know what you think.

Please let me know if you have any further questions or concerns.

--
Kind Regards,
Igor Netkachev
Technical Support Engineer
Red Hat Global Support Services

Note You need to log in before you can comment on or make changes to this bug.