Bug 1474883 - Cannot import html5lib: ImportError: No module named webencodings
Cannot import html5lib: ImportError: No module named webencodings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-html5lib (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Praveen Kumar
Fedora Extras Quality Assurance
:
Depends On: 1474930
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 10:44 EDT by Randy Barlow
Modified: 2017-07-27 17:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-html5lib-0.999999999-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 17:58:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2017-07-25 10:44:56 EDT
Description of problem:
I cannot import html5lib on my Rawhide system due to webencodings not being available.


Version-Release number of selected component (if applicable):
python2-html5lib-0.999999999-1.fc27.noarch


How reproducible:
Every time.


Steps to Reproduce:
1. $ python
2. >>> import html5lib


Actual results:
$ python                                                      
Python 2.7.13 (default, Jun 26 2017, 10:16:32)             
[GCC 7.1.1 20170526 (Red Hat 7.1.1-2)] on linux2           
Type "help", "copyright", "credits" or "license" for more information.                                                
>>> import html5lib          
Traceback (most recent call last):                         
  File "<stdin>", line 1, in <module>                      
  File "/usr/lib/python2.7/site-packages/html5lib/__init__.py", line 16, in <module>                                  
    from .html5parser import HTMLParser, parse, parseFragment                                                         
  File "/usr/lib/python2.7/site-packages/html5lib/html5parser.py", line 11, in <module>                               
    from . import _inputstream                             
  File "/usr/lib/python2.7/site-packages/html5lib/_inputstream.py", line 9, in <module>                               
    import webencodings      
ImportError: No module named webencodings


Expected results:
It should be possible to import html5lib.


Additional info:
Bodhi uses bleach, which needs html5lib, so this is blocking Bodhi from building on Rawhide.
Comment 1 Randy Barlow 2017-07-25 10:56:36 EDT
It looks like this happened in the recent update from 0.999 to 0.999999999. 0.999 did not depend on webencodings:

https://github.com/html5lib/html5lib-python/blob/0.999/requirements.txt

But the new version does:

https://github.com/html5lib/html5lib-python/blob/0.999999999/requirements.txt
Comment 2 Randy Barlow 2017-07-25 11:00:00 EDT
webencodings does not appear to be packaged for Fedora yet. I will take some time today to package it, and once we get it approved and in Rawhide we can update this package to Require it.
Comment 3 Kevin Fenzi 2017-07-25 11:10:45 EDT
This is my fault. I thought it was only using that for tests. ;(
Comment 4 Randy Barlow 2017-07-25 13:01:45 EDT
python-webencodings-0.5.1-1.fc27 is now built on Rawhide, so this ticket can now be fixed. Thanks!
Comment 5 Randy Barlow 2017-07-27 17:58:56 EDT
Thanks for fixing this for me Kevin!

Note You need to log in before you can comment on or make changes to this bug.