Bug 1474910 - Host and Platform
Host and Platform
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
ChangeAcceptedF27, SystemWideChange R...
:
Depends On: 1491023 1493170
Blocks: 1474931
  Show dependency treegraph
 
Reported: 2017-07-25 11:40 EDT by Jan Kurik
Modified: 2017-10-30 16:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-30 12:59:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2017-07-25 11:40:34 EDT
This is a tracking bug for Change: Host and Platform
For more details, see: https://fedoraproject.org//wiki/Changes/Host_and_Platform

Host and Platform is an evolution of the Base Runtime module concept introduced in Fedora 26 Boltron, splitting the minimal system further into independent modules allowing for greater flexibility when composing and maintaining the base system.
Comment 1 Jan Kurik 2017-08-10 02:18:17 EDT
On 2017-Aug-01, we have reached the Fedora 27 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be enabled at Change Completion deadline as well.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo for 2017-Aug-11 meeting.

Please set this bug to the MODIFIED state to indicate it is already in the testable state, or provide an update describing the current state of implementation for this Change.

Thank you,
Jan
Comment 2 Petr Šabata 2017-08-11 06:43:16 EDT
We have builds of Host & Platform modules ready.

They're still being worked on -- polished, minimized (unbundling dynamic languages) and extended (more useful features) at the same time.  But we have something :) There's also a compose that includes host, platform and shim, but it's currently defunct due to a robosignatory configuration problem.  It's being fixed today (https://pagure.io/robosignatory/pull-request/15).

Switching to MODIFIED.
Comment 3 Jan Kurik 2017-08-15 03:32:25 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 4 Jan Kurik 2017-09-06 09:38:35 EDT
On 2017-Sep-05 we reached the "Change Checkpoint: 100% Code Complete Deadline" milestone for Fedora 27 release. At this point all the Changes not at least in "ON_QA" state should be brought to FESCo for review. Please update the state of this bug to "ON_QA" if it is already 100% completed. Please let me know in case you have any trouble with the implementation and the Change needs any help or review.

Thanks, Jan
Comment 5 Petr Šabata 2017-09-07 14:04:34 EDT
The content definition is still not 100% complete.  Host & Platform currently pull in packages with broken deps; this needs to be ironed out.

The H&P deliverables are/were blocked by several things:

* signing issues (hopefully resolved as of today)

* PDC not registering all module component builds (tracked)

* incorrect variant of lorax in the buildroot, requiring packages we don't
  intend to ship via anaconda-gui (todo; hopefully we can reuse F26 templates)

* possibly some packages missing (investigating; at least fedora-logos was
  added today)

I will attend the FESCo meeting tomorrow.
Comment 6 Fedora Blocker Bugs Application 2017-10-19 13:05:06 EDT
Proposed as a Blocker for 27-server-beta by Fedora user mattdm using the blocker tracking app because:

 Host and Platform are by definition the fundamental building blocks.
Comment 7 Stephen Gallagher 2017-10-30 12:59:04 EDT
We have composes that are built from the host and platform modules (among others). I'm calling this one complete.
Comment 8 Geoffrey Marr 2017-10-30 16:01:48 EDT
Discussed during the 2017-10-30 blocker review meeting: [1]

The decision to classify this bug as a RejectedBlocker was made as we don't really see that there's any utility in having a Change tracking bug as a release blocker, the release blocker process is about concrete functional bugs; any functional bug caused by the Change being incomplete should be evaluated as a blocker on its own merits.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-10-30/f27-blocker-review.2017-10-30-16.00.txt

Note You need to log in before you can comment on or make changes to this bug.