Bug 147497 - Memory leak in rhn-applet-gui?
Memory leak in rhn-applet-gui?
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhn-applet (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-08 11:18 EST by Jeff Layton
Modified: 2014-06-18 03:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-26 15:33:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2005-02-08 11:18:25 EST
Description of problem:
rhn-applet-gui is leaking memory badly on 2 of my workstations. One of
them had only been up for 6 days and it had grown to 256M in size.

Version-Release number of selected component (if applicable):
Recently patched RHEL-3 AS -- rhn-applet-2.1.18-4

How reproducible:
Very. It may be a cross platform problem, but I've only observed it so
far on i386 (only because I have no other arch'es on my desktop to
test this on).

Steps to Reproduce:
1. Fire up rhn-applet-gui.
2. Run top, hit 'M' to sort by memory usage
3. Wait for rhn-applet-gui to bubble to top of list

Actual results:
It grows fairly rapidly -- about .1M per min or so (guestimating here,
 I haven't measured it).

Expected results:
It should stay relatively constant in size.

Additional info:
Comment 1 Robin Norwood 2006-10-17 12:00:58 EDT
mass reassign to mmccune
Comment 2 Jeff Layton 2007-03-26 15:33:29 EDT
I'm thinking this is no longer a problem...closing.

Note You need to log in before you can comment on or make changes to this bug.