Bug 1475006 - Gnocchi fails to create manila.share.size metric
Gnocchi fails to create manila.share.size metric
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
low Severity low
: ga
: 12.0 (Pike)
Assigned To: Victoria Martinez de la Cruz
Sasha Smolyak
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 16:22 EDT by Victoria Martinez de la Cruz
Modified: 2017-12-13 16:44 EST (History)
4 users (show)

See Also:
Fixed In Version: openstack-ceilometer-9.0.2-0.20170925173740.1057885.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:44:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1706440 None None None 2017-07-25 16:22 EDT

  None (edit)
Description Victoria Martinez de la Cruz 2017-07-25 16:22:29 EDT
Description of problem:

availability_zone and name parameters were marked as required for the manila share resource-type while these are not always needed by manila. This makes the creation of the manila.share.size metric file and hence the displayed data is not accurate.


Version-Release number of selected component (if applicable): P3


How reproducible: In a deployment with manila (notifications enabled) and ceilometer with gnocchi configured as the backend, create a new manila share.


Steps to Reproduce:
1. Create a manila share
2. Check the metric list

Actual results: The metric cannot be created due to missing required attributes.

Expected results: Gnocchi should collect manila.share.size metrics when receiving manila.create.*, manila.delete.*, manila.shrink.* and manila.extend.* events and show them on the metric list.


Additional info:
Comment 6 Sasha Smolyak 2017-12-13 06:58:04 EST
The attributes are there, nothing is missing anymore.
Verified.
The code is there
Comment 9 errata-xmlrpc 2017-12-13 16:44:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.