Bug 1475032 - RFE: Object granular encryption support
RFE: Object granular encryption support
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
3.0
Unspecified Unspecified
high Severity medium
: rc
: 3.0
Assigned To: Matt Benjamin (redhat)
Shreekar
Bara Ancincova
: FutureFeature
Depends On:
Blocks: 1494421
  Show dependency treegraph
 
Reported: 2017-07-25 17:42 EDT by Uday Boppana
Modified: 2017-12-05 18:38 EST (History)
9 users (show)

See Also:
Fixed In Version: RHEL: ceph-12.1.4-1.el7cp Ubuntu: ceph_12.1.4-2redhat1xenial
Doc Type: Enhancement
Doc Text:
.Support for S3 server-side encryption The Ceph Object Gateway now supports the Amazon Simple Storage Service (S3) server-side encryption. For details, see the link:https://access.redhat.com/documentation/en-us/red_hat_ceph_storage/3/html-single/developer_guide/#s3-api-encryption[S3 API Server-side Encryption] section in the Developer Guide for Red{nbsp}Hat Ceph Storage 3.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-05 18:38:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uday Boppana 2017-07-25 17:42:59 EDT
Object granular encryption support in RGW.
Comment 2 Matt Benjamin (redhat) 2017-07-27 14:53:07 EDT
Per Uday, this connotes SSE-C and -maybe- SSE-KMS w/Barbican as the KMS.
Comment 9 errata-xmlrpc 2017-12-05 18:38:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387

Note You need to log in before you can comment on or make changes to this bug.