Bug 1475111 - Missing discard for /
Missing discard for /
Status: CLOSED CURRENTRELEASE
Product: ovirt-node
Classification: oVirt
Component: Installation & Update (Show other bugs)
4.1
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-4.1.4-1
: ---
Assigned To: Ryan Barry
Qin Yuan
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-26 01:39 EDT by Qin Yuan
Modified: 2017-08-23 04:04 EDT (History)
13 users (show)

See Also:
Fixed In Version: imgbased-0.9.35-0.1.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-23 04:04:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: blocker+
cshao: testing_ack+


Attachments (Terms of Use)
/var/log*,/tmp/*,sosreport (9.35 MB, application/x-gzip)
2017-07-26 01:39 EDT, Qin Yuan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79835 master MERGED Make sure / is checked for discard 2017-07-26 07:29 EDT
oVirt gerrit 79836 ovirt-4.1 MERGED Make sure / is checked for discard 2017-07-26 07:30 EDT

  None (edit)
Description Qin Yuan 2017-07-26 01:39:04 EDT
Created attachment 1304591 [details]
/var/log*,/tmp/*,sosreport

Description of problem:
There is no discard option for /, no matter choosing auto partitioning or custom partitioning.

Take auto partitioning as an example, after installation finished, the content of /etc/fstab is as following:

[root@fctest ~]# cat /etc/fstab
#
# /etc/fstab
# Created by anaconda on Wed Jul 26 03:47:37 2017
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/rhvh_fctest/rhvh-4.1-0.20170721.0+1 / ext4 defaults 1 1
UUID=c1a3dc66-2ecf-4c42-80df-b5a4f87e3116 /boot                   ext4    defaults        1 2
/dev/mapper/rhvh_fctest-home /home ext4 defaults,discard 1 2
/dev/mapper/rhvh_fctest-tmp /tmp ext4 defaults,discard 1 2
/dev/mapper/rhvh_fctest-var /var ext4 defaults,discard 1 2
/dev/mapper/rhvh_fctest-var_log /var/log ext4 defaults,discard 1 2
/dev/mapper/rhvh_fctest-var_log_audit /var/log/audit ext4 defaults,discard 1 2
/dev/mapper/rhvh_fctest-swap swap                    swap    defaults        0 0 


Version-Release number of selected component (if applicable):
RHVH-4.1-20170723.1-RHVH-x86_64-dvd1.iso
redhat-virtualization-host-4.1-20170721.0
imgbased-0.9.34-0.1.el7ev.noarch 


How reproducible:
100%


Steps to Reproduce:
1. Install redhat-virtualization-host-4.1-20170721.0 via PXE or ISO.
2. Choose auto partitioning on Anaconda GUI, and finish other mandatory steps.
3. After installation finished, log into system, run 'cat /etc/fstab' 


Actual results:
1. After step3, there is no discard option for / 


Expected results:
1. After step3, there is a discard option for /. 


Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2017-07-26 07:28:03 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Qin Yuan 2017-07-30 23:41:18 EDT
Verify Versions:
redhat-virtualization-host-4.1-20170728.0
imgbased-0.9.36-0.1.el7ev.noarch

Verify Steps and Results:
The steps are as specified in comment #0, choosing PXE

[root@dhcp-10-111 ~]# cat /etc/fstab
#
# /etc/fstab
# Created by anaconda on Mon Jul 31 11:21:02 2017
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/rhvh_dhcp-10-111/rhvh-4.1-0.20170728.0+1 / ext4 defaults,discard 1 1
UUID=3d922c93-3b54-41d4-9d61-851836a29dab /boot                   ext4    defaults        1 2
/dev/mapper/rhvh_dhcp--10--111-home /home ext4 defaults,discard 1 2
/dev/mapper/rhvh_dhcp--10--111-tmp /tmp ext4 defaults,discard 1 2
/dev/mapper/rhvh_dhcp--10--111-var /var ext4 defaults,discard 1 2
/dev/mapper/rhvh_dhcp--10--111-var_log /var/log ext4 defaults,discard 1 2
/dev/mapper/rhvh_dhcp--10--111-var_log_audit /var/log/audit ext4 defaults,discard 1 2
/dev/mapper/rhvh_dhcp--10--111-swap swap                    swap    defaults        0 0

There is discard for /, so set the status to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.