Bug 1475113 - [RFE] Metrics should include information about the RHV-M server (CPU, memory, network, etc.)
[RFE] Metrics should include information about the RHV-M server (CPU, memory,...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-metrics
Classification: oVirt
Component: RFEs (Show other bugs)
1.0.5
Unspecified Unspecified
high Severity medium
: ovirt-4.2.0
: ---
Assigned To: Shirly Radco
Lukas Svaty
: FutureFeature, Reopened
Depends On: 950813
Blocks: 1475135
  Show dependency treegraph
 
Reported: 2017-07-26 01:47 EDT by Shirly Radco
Modified: 2017-12-24 05:26 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
collectd and fluentd are deployed and configured to send data, such as CPU usage, memory, interface metrics, to a remote metrics store as part of the Metrics Store feature.
Story Points: ---
Clone Of: 950813
Environment:
Last Closed: 2017-12-20 05:59:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Metrics
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2?
gklein: testing_plan_complete+
rule-engine: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description Shirly Radco 2017-07-26 01:47:21 EDT
Add the ability to monitor the oVirt manager server's stats/vitals.

This would allow monitoring the health of the manager over time.

Additional oVirt manager cpu usage, memory usage, and network utilization among others.
Comment 1 Yaniv Lavi 2017-07-31 05:17:09 EDT
This should be MODIFIED, no?
Comment 2 Lukas Svaty 2017-08-02 09:45:17 EDT
I believe this indeed require doctext, on which information are available from which measurments. Please reconsider.

Also please provide verification steps.
Comment 3 Shirly Radco 2017-08-02 09:55:37 EDT
As part of the metrics store we enabled collectd cpu, memory, interface plugins that will provide the required statistics for both engine and hosts.

The specific stats that collectd provides can be seen in collectd documentation.
And will be part of the general feature documentation soon.
Comment 4 Lukas Svaty 2017-10-09 09:08:21 EDT
samples are reported from collectors:
collectd.plugin:(cpu|memory|interface)

verified in ovirt-engine-metrics-1.1.1-0.0.master.20171001113530.el7.centos.noarch
Comment 5 Red Hat Bugzilla Rules Engine 2017-11-21 04:13:12 EST
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.
Comment 6 Sandro Bonazzola 2017-12-20 05:59:18 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.