Bug 1475136 - [Perf] : Large file sequential reads are off target by ~38% on FUSE/Ganesha
[Perf] : Large file sequential reads are off target by ~38% on FUSE/Ganesha
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute (Show other bugs)
3.3
x86_64 Linux
unspecified Severity high
: ---
: RHGS 3.3.0
Assigned To: Nithya Balachandran
Ambarish
: Regression
Depends On: 1476665
Blocks: 1417151 1475176 1479303
  Show dependency treegraph
 
Reported: 2017-07-26 03:14 EDT by Ambarish
Modified: 2017-09-21 01:04 EDT (History)
15 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-39
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1476665 (view as bug list)
Environment:
Last Closed: 2017-09-21 01:04:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ambarish 2017-07-26 03:14:36 EDT
Description of problem:
-----------------------

A regression seems to have been introduced in recent bits on large file seq reads :

3.3 : 2480044.05 kB/sec	
3.8.4-35 : 1538178.2 kB/sec


Regression : ~38%

This is on a vanilla volume,without PR,NL,mdcache.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------

3.8.4-35

How reproducible:
-----------------

100%

Additional info:
----------------
Volume Name: testvol
Type: Distributed-Replicate
Volume ID: 4b52bfb8-28fd-4e0f-8ee0-eb8116a296c4
Status: Started
Snapshot Count: 0
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: gqas013.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick0
Brick2: gqas005.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick1
Brick3: gqas006.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick2
Brick4: gqas008.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick3
Options Reconfigured:
server.allow-insecure: on
performance.stat-prefetch: off
transport.address-family: inet
nfs.disable: on
Comment 5 Ambarish 2017-07-26 03:22:54 EDT
(In reply to Ambarish from comment #0)
> Description of problem:
> -----------------------
> 
> A regression seems to have been introduced in recent bits on large file seq
> reads :
> 
> 3.3 : 2480044.05 kB/sec	
> 3.8.4-35 : 1538178.2 kB/sec
> 
> 
> Regression : ~38%
> 
> This is on a vanilla volume,without PR,NL,mdcache.
> 
> Version-Release number of selected component (if applicable):
> -------------------------------------------------------------
> 
> 3.8.4-35
> 
> How reproducible:
> -----------------
> 
> 100%
> 
> Additional info:
> ----------------
> Volume Name: testvol
> Type: Distributed-Replicate
> Volume ID: 4b52bfb8-28fd-4e0f-8ee0-eb8116a296c4
> Status: Started
> Snapshot Count: 0
> Number of Bricks: 2 x 2 = 4
> Transport-type: tcp
> Bricks:
> Brick1: gqas013.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick0
> Brick2: gqas005.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick1
> Brick3: gqas006.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick2
> Brick4: gqas008.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick3
> Options Reconfigured:
> server.allow-insecure: on
> performance.stat-prefetch: off
> transport.address-family: inet
> nfs.disable: on

Ugh!

Typo.

I meant :

 3.2 : 2480044.05 kB/sec	
 3.8.4-35 : 1538178.2 kB/sec
 
 
 Regression : ~38%
Comment 20 Atin Mukherjee 2017-07-31 09:03:28 EDT
upstream patch : https://review.gluster.org/#/c/17922/
Comment 22 Atin Mukherjee 2017-08-07 02:40:57 EDT
Patch mentioned in comment 20 is not valid any more. New upstream patch : https://review.gluster.org/#/c/17976/
Comment 28 Karan Sandha 2017-08-11 04:32:36 EDT
Tested on 3.8.4-39 with Sequential Reads on FUSE Mount and regressions were not seen. Ran 2 different iterations to verify the fix. 
Waiting for ganesha results to mark it as verified. Over to you ambarish.
Comment 29 Ambarish 2017-08-13 02:45:19 EDT
Consistently close numbers to my baseline on EC/FUSE and Dist-Rep/Ganesha : 

*EC/FUSE*:

Baseline : 2644530 kB/sec
3.8.4-40 : 2477115.03 kB/sec

Regression : -6%

*Dist/Rep/Ganesha*:

Baseline(3.2) : 1430299 kB/sec
3.8.4-40 : 1426718 kB/sec

Regression : Not much


These are allowable limits that my tests are allowed to have in between releases.

Based on https://bugzilla.redhat.com/show_bug.cgi?id=1475136#c28,and this one,I am moving the bug to Verified.
Comment 31 errata-xmlrpc 2017-09-21 01:04:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.