Bug 147525 - RFE: rpm backend database extension - CDB patches
Summary: RFE: rpm backend database extension - CDB patches
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL: http://www.aerov.jussieu.fr/~thauvin/...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-08 19:35 UTC by R P Herrold
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 20:38:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description R P Herrold 2005-02-08 19:35:55 UTC
Part of the current RPM db backend extension project

13:11  Nanar> jbj:
http://www.aerov.jussieu.fr/~thauvin/rpmconstant-0.0.3.tar.gz
13:12  Nanar> jbj: I made a library for my need, but feel free to comment,
              integrate, patch, ect...
13:14  jbj> Nanar: hang the ptr in bugzilla please. I'll try to
integrate this
            week. perhaps not for rpm-4.4.1 which I need to get out
lest the
            features creep on me, but immediately thereafter.
13:15  jbj> just snip the scollback, more than enough.
13:15  Nanar> ok no problem and no emergency
13:16  Nanar> I back home and fill bugzilla ASAP

Comment 1 R P Herrold 2005-02-08 19:36:48 UTC
13:33  rsc> Dumb question: Why does rpm have sqlite support? Tomorrow
we've
            requirements to xorg-x11 or qt? :-S
13:34  fray> rsc, because there are some of us who can no longer deal
with the
             support problems of BerkleyDB in our environments
13:39  _jasonc_> and bdb licensing has scared away a corporation or
two that
                 would like to use rpm
13:50  jbj> _jasonc_: way more complicated than obvious. cheap
bastards imho.
13:50  _jasonc_> jbj: not necessarily debating merits of that argument
13:50  _jasonc_> just stating that it has been an issue
13:51  jbj> resc: yes, licensing is main reason. stability too, 2 years of
            wrestling nptl has generated much bdbd hatred unnecessarily.


Comment 2 Rahul Sundaram 2005-08-13 23:43:49 UTC
Setting priority to high since patch is included

Comment 3 Paul Nasrat 2005-11-28 20:38:25 UTC
Misleading subject as no db related patches.  The utility needs some work:

[pauln@enki rpmconstant-0.0.3]$ ./rpmconstant name
Segmentation fault
[pauln@enki rpmconstant-0.0.3]$ ./rpmconstant -c rpmtag name
name: 1000

Not considering for inclusion at this time, if it gets fixed up please submit
via rpm-devel list.



Note You need to log in before you can comment on or make changes to this bug.