Bug 1475253 - ri cannot find documentation data for current ruby distribution
ri cannot find documentation data for current ruby distribution
Status: CLOSED DUPLICATE of bug 1458131
Product: Fedora
Classification: Fedora
Component: rubygems (Show other bugs)
26
All All
unspecified Severity high
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-26 05:46 EDT by Francesco Giancane
Modified: 2017-07-26 07:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-26 07:13:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample outputs from ri String (2.37 KB, application/octet-stream)
2017-07-26 05:46 EDT, Francesco Giancane
no flags Details
tar of files failing.log and success.log (5.00 KB, application/x-tar)
2017-07-26 05:51 EDT, Francesco Giancane
no flags Details

  None (edit)
Description Francesco Giancane 2017-07-26 05:46:38 EDT
Created attachment 1304672 [details]
sample outputs from ri String

Description of problem: The 'ri' command of the standard Ruby distribution fails, saying it is not possible to find documentation data. 

The standard Ruby distribution has been installed using dnf.

The problem is to be found in the ruby-doc sub package: documentation data is installed in the /usr/share/ri/system root folder, while it should be installed in /usr/share/ri/${RUBY_VERSION}/system root folder.

The ruby-doc SPECFILE should be modified accordingly in order to fix this issue.


Version-Release number of selected component (if applicable): 
[fgiancane8@saturno ~]$ dnf info ruby-doc
Ultima verifica della scadenza dei metadati: 11:29:52 fa il mer 26 lug 2017 00:04:47 CEST.
Pacchetti installati
Nome         : ruby-doc
Versione     : 2.4.1
Rilascio     : 79.fc26
Arch         : noarch
Dim.         : 24 M
Sorgente     : ruby-2.4.1-79.fc26.src.rpm
Repo         : @System
Dal repo     : fedora
Sommario     : Documentation for ruby
URL          : http://ruby-lang.org/
Licenza      : (Ruby or BSD) and Public Domain and MIT and CC0 and zlib and UCD
Descrizione  : This package contains documentation for ruby.

How reproducible: Always reproducible 


Steps to Reproduce:
1. Install standard Ruby distribution (sudo dnf install rubygems ruby ruby-doc 
2. Ask for documentation (e.g. ri String), verifying that nothing is found (see attachment)
3. Use the 'ri --list-doc-dirs' to verify the documentation search path.
4. Verify that the system entry of the previous command does not exist.
5. As a workaround, it is possible to create a dummy folder in /usr/share/ri, containing a symlink to the ruby-doc content, to replicate this structure:

/usr/share/ri/system

/usr/share/ri/2.4.0/system -> ../system

In this way ri happily finds all the documentation required (and installed).

Actual results:
ri cannot find any standard documentation installed in the search path, even if available.


Expected results:
ri should find and report installed documentation in the search path as available.


Additional info:
The example output of 'ri String' command is redirected onto the files attached. Failing.log is when ri does not find any doc, success.log is when it is found, just after creating the dummy folder with the symbolic link.
Comment 1 Francesco Giancane 2017-07-26 05:51 EDT
Created attachment 1304674 [details]
tar of files failing.log and success.log
Comment 2 Mamoru TASAKA 2017-07-26 07:13:00 EDT

*** This bug has been marked as a duplicate of bug 1458131 ***

Note You need to log in before you can comment on or make changes to this bug.