Bug 1475331 - [RFE] get-state CLI should capture rebalance estimation time for the ongoing rebalance for a volume
[RFE] get-state CLI should capture rebalance estimation time for the ongoing ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.1
Assigned To: Atin Mukherjee
Bala Konda Reddy M
: FutureFeature, ZStream
Depends On:
Blocks: 1475686
  Show dependency treegraph
 
Reported: 2017-07-26 08:52 EDT by Samikshan Bairagya
Modified: 2017-11-28 22:29 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-45
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-28 22:29:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samikshan Bairagya 2017-07-26 08:52:23 EDT
Description of problem:
get-state CLI should capture rebalance estimation time for the ongoing rebalance for a volume as obtained currently in rebalance status
Comment 2 Samikshan Bairagya 2017-07-26 09:12:18 EDT
Upstream patch: https://review.gluster.org/17862
Comment 5 Bala Konda Reddy M 2017-10-11 11:46:30 EDT
BUILD : 3.8.4-48

Rebalance estimation time is getting captured with gluster get-state

Volume1.rebalance.id: 1bc023ee-0ee7-447f-b2f6-461054900891
Volume1.rebalance.status: started
Volume1.rebalance.failures: 0
Volume1.rebalance.skipped: 2286
Volume1.rebalance.lookedup: 59681
Volume1.rebalance.files: 5091
Volume1.rebalance.data: 712.0MB
Volume1.time_left: 3743

Hence marking it as verified
Comment 8 errata-xmlrpc 2017-11-28 22:29:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3276

Note You need to log in before you can comment on or make changes to this bug.