Bug 1475333 - [RFE] get-state CLI should mark the respective brick as arbiter if volume type is arbiter
[RFE] get-state CLI should mark the respective brick as arbiter if volume typ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.1
Assigned To: Atin Mukherjee
Bala Konda Reddy M
: FutureFeature, ZStream
Depends On:
Blocks: 1475686
  Show dependency treegraph
 
Reported: 2017-07-26 08:56 EDT by Samikshan Bairagya
Modified: 2017-11-28 22:29 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-45
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-28 22:29:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samikshan Bairagya 2017-07-26 08:56:18 EDT
Description of problem:
Currently the get-state CLI output doesn't display if a brick is an arbiter brick or not. get-state should mark the arbiter brick clearly if the volume type is arbiter.
Comment 2 Samikshan Bairagya 2017-07-26 09:12:41 EDT
Upstream patch: https://review.gluster.org/17864
Comment 3 Atin Mukherjee 2017-09-04 02:33:09 EDT
downstream patch : https://code.engineering.redhat.com/gerrit/#/c/117149
Comment 5 Bala Konda Reddy M 2017-10-11 03:32:53 EDT
Build: 3.8.4-48

The respective brick is marked as arbiter and volume type is replicate

[Volumes]
Volume1.name: testvol_arb
Volume1.id: e03f984c-62cc-42f7-844d-7cce3a8ae7d3
Volume1.type: Replicate
Volume1.transport_type: tcp
Volume1.status: Started
Volume1.brickcount: 3
Volume1.Brick1.path: 10.70.37.104:/bricks/brick0/ab_1
Volume1.Brick1.hostname: 10.70.37.104
Volume1.Brick1.port: 49152
Volume1.Brick1.rdma_port: 0
Volume1.Brick1.status: Started
Volume1.Brick1.spacefree: 11833729024Bytes
Volume1.Brick1.spacetotal: 53384052736Bytes
Volume1.Brick2.path: 10.70.37.100:/bricks/brick0/ab_2
Volume1.Brick2.hostname: 10.70.37.100
Volume1.Brick3.path: 10.70.37.92:/bricks/brick0/ab_3
Volume1.Brick3.hostname: 10.70.37.92
Volume1.Brick3.is_arbiter: 1

Hence marking it as verified.
Comment 8 errata-xmlrpc 2017-11-28 22:29:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3276

Note You need to log in before you can comment on or make changes to this bug.