This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1475335 - [mix-version] fail to deploy osp 10 overcloud from osp 11 undercloud with osp10 rhel 7.4 images
[mix-version] fail to deploy osp 10 overcloud from osp 11 undercloud with osp...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates-compat (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
medium Severity medium
: async
: 11.0 (Ocata)
Assigned To: Mike Burns
Raviv Bar-Tal
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-26 09:07 EDT by Raviv Bar-Tal
Modified: 2017-08-01 21:03 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-compat-5.2.0-25.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 21:03:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
controller messages log (1.65 MB, text/plain)
2017-07-26 09:07 EDT, Raviv Bar-Tal
no flags Details

  None (edit)
Description Raviv Bar-Tal 2017-07-26 09:07:06 EDT
Created attachment 1304788 [details]
controller messages log

Description of problem:
Trying to deploy osp 10 overcloud using compat THT and osp10 rhel 7.4 based images fails on dependence  issues

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install osp11 undercloud.
2. load osp10 images (ironic and overcloud, introspect your nodes)
3. try to deploy osp10 overcloud with comapt THT (/usr/share/openstack-tripleo-heat-templates/compat)

Actual results:
overcloud deploy fails

Expected results:
overcloud deploy pass

Additional info:
/var/log/message from the controller is attached
Comment 1 Raviv Bar-Tal 2017-07-27 01:51:28 EDT
Hi Mike,
This looks like packing issue.
I am able to deploy osp10 using latest osp10 templates,
But unable to deploy using osp11 compat templates.

The package that works from osp10:
openstack-tripleo-heat-templates-5.2.0-25.el7ost.noarch

The package that fails from osp11:
openstack-tripleo-heat-templates-compat-5.2.0-20.el7ost.noarch
Comment 6 errata-xmlrpc 2017-08-01 21:03:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2407

Note You need to log in before you can comment on or make changes to this bug.