Bug 1475348 - OSP11 -> OSP12 upgrade: leaves clustercheck xinetd service running on the host
OSP11 -> OSP12 upgrade: leaves clustercheck xinetd service running on the host
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
urgent Severity urgent
: beta
: 12.0 (Pike)
Assigned To: Damien Ciabrini
Marius Cornea
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-26 09:28 EDT by Marius Cornea
Modified: 2018-02-05 14:10 EST (History)
9 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-7.0.0-0.20170913050524.0rc2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:44:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1706612 None None None 2017-07-26 09:29 EDT
OpenStack gerrit 487889 None None None 2017-08-14 09:50 EDT
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-15 20:43:25 EST

  None (edit)
Description Marius Cornea 2017-07-26 09:28:35 EDT
When performing a major upgrade from a non-containerized Ocata to a containerized Pike, a new
container dedicated to galera's clustercheck is created to serve galera healthcheck queries on port 9200.

However, the clustercheck service is still configured on the xinet daemon running on the host, and after the upgrade that port is still held and served by xinetd on the host.
Comment 1 Michele Baldessari 2017-08-14 09:50:41 EDT
Upstream reviews has just been +Aed
Comment 2 Michele Baldessari 2017-08-16 03:35:51 EDT
Upstream review has merged, moving to POST
Comment 7 errata-xmlrpc 2017-12-13 16:44:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.