Bug 1475373 - (CVE-2017-11362) CVE-2017-11362 php: Stack-based buffer over-read in msgfmt_parse_message function
CVE-2017-11362 php: Stack-based buffer over-read in msgfmt_parse_message func...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20170717,repor...
: Security
Depends On: 1475374
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-26 10:03 EDT by Pedro Sampaio
Modified: 2017-07-26 10:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Sampaio 2017-07-26 10:03:20 EDT
In PHP 7.x before 7.0.21 and 7.1.x before 7.1.7,
ext/intl/msgformat/msgformat_parse.c does not restrict the locale
length, which allows remote attackers to cause a denial of service
(stack-based buffer overflow and application crash) or possibly have
unspecified other impact within International Components for Unicode
(ICU) for C/C++ via a long first argument to the msgfmt_parse_message
function.

Upstream bug:

https://bugs.php.net/bug.php?id=73473

Upstream patch:

http://git.php.net/?p=php-src.git;a=commit;h=95c4564f939c916538579ef63602a3cd31941c51
Comment 1 Pedro Sampaio 2017-07-26 10:04:17 EDT
Created php tracking bugs for this issue:

Affects: fedora-all [bug 1475374]

Note You need to log in before you can comment on or make changes to this bug.