Bug 1475436 - [RFE] Update Fast datapath production channel to OVS 2.9 and DPDK 17.11 for RHEL 7.5
Summary: [RFE] Update Fast datapath production channel to OVS 2.9 and DPDK 17.11 for ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch
Version: 7.3
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Timothy Redaelli
QA Contact: ovs-qe
Ioanna Gkioka
URL:
Whiteboard:
: 1539705 (view as bug list)
Depends On: 1023943 1369362 1413962 1449485 1454753 1462970 1468289 1489465 1499127 1501418 1505776 1506245 1510037 1527156 1528229 1529481 1532719 1539608 1545387
Blocks: 1489045
TreeView+ depends on / blocked
 
Reported: 2017-07-26 16:49 UTC by Anita Tragler
Modified: 2018-05-31 17:46 UTC (History)
19 users (show)

Fixed In Version: openvswitch-2.9.0-1.el7fdp
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_openvswitch_ rebased to version 2.9.0 and DPDK to 17.11 The _openvswitch_ packages have been upgraded to upstream version 2.9.0 and Data Plane Development Kit (DPDK) to 17.11, which provide a number of bug fixes and enhancements over the previous version. Notable changes include: * Support for running the `ovs-vswitchd` and `ovsdb-server` commands as non-root users by default. * Open Virtual Network (OVN) features have been added for Layer 3 gateway High Availability (L3 gateway HA) and routing. * Support for Network Service Header (NSH) with VXLAN Generic Protocol Extension (VXLAN-GPE) for Open vSwitch (OVS) and OVS-DPDK. * The Exact-Match Cache (EMC) removed and OVS can scale to millions of flows. * The *openvswitch* service updated. * Support for the transient ports. * Support for Maximum Transmission Unit (MTU) negotiation for Jumbo frames. * Enabled the `vIOMMU` function in the DPDK guest and OVS-DPDK in the host.
Clone Of:
Environment:
Last Closed: 2018-03-19 10:19:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0550 0 None None None 2018-03-19 10:21:24 UTC

Description Anita Tragler 2017-07-26 16:49:34 UTC
Description of problem:
Must update Fast datpath content set (OVS, OVS-DPDK) to OVS 2.9 + DPKD 17.11 on FD production channel to provide stable datapath content for RHEL 7.5 release. 
Requires Platform/Virt/Perf QE CI, regression and performance benchmarking for affected datapath features when new bugs or fixes are pushed
FD production channel OVS 2.9 will be consumed by RHV 4.2, OCP 3.x, RHOSP 13 

Must have features
- OVN features for HA L3 gateway and routing + others
- NSH with VXLAN-gpe for OVS and OVS-DPDK
- Exact Match Cache removal and optmizations to scale to millions of flows
- OVS in-service hot update, measure update or upgrade time; update time <1s
- MTU negotiation for Jumbo frames, workloads with different MTU requirements
- DPDK guest with vIOMMU and OVS-DPDK in host
Should support
- OVS-DPDK inservice update with dpdk ports 
- SHould support OVS and OVS-DPDK for BGP VPNs with MPLS over GRE and MPLS over UDP encapsulation, routes learned via Quagga and installed in OVS

Version-Release number of selected component (if applicable):
Update to OVS 2.9 and DPDK 17.11 for RHEL 7.5

How reproducible:
RFE new feature reqquest

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Flavio Leitner 2018-02-16 16:32:04 UTC
*** Bug 1539705 has been marked as a duplicate of this bug. ***

Comment 36 Ioanna Gkioka 2018-03-19 09:26:31 UTC
The openvwitch component is delivered through the fast datapath channel, it is not documented in release notes.

Comment 37 errata-xmlrpc 2018-03-19 10:19:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0550


Note You need to log in before you can comment on or make changes to this bug.