Bug 1475447 - SELinux Policy module won't install.
SELinux Policy module won't install.
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: nagios (Show other bugs)
el6
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen John Smoogen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-26 13:30 EDT by Fred Wittekind IV
Modified: 2017-11-16 11:53 EST (History)
13 users (show)

See Also:
Fixed In Version: nagios-4.3.4-4.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-16 11:53:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred Wittekind IV 2017-07-26 13:30:42 EDT
Description of problem:


Version-Release number of selected component (if applicable):
nagios-4.3.2-5.el6.x86_64
nagios-selinux-4.3.2-5.el6.x86_64
selinux-policy-targeted-3.7.19-307.el6_9.2.noarch

How reproducible:


Steps to Reproduce:
1. yum install nagios-selinux
2. semodule -l |grep nagios
3.

Actual results:
nagios 1.8.0

Expected results:
nagios 1.8.0
nagios_epel

Additional info:
Post install script includes: 
semodule -i /usr/share/selinux/packages/nagios_epel.pp 2>/dev/null || :

Package installed module in 
/usr/share/selinux/packages/nagios/nagios_epel.pp
Not:
/usr/share/selinux/packages/nagios_epel.pp

Manual install attempt:
# semodule -i /usr/share/selinux/packages/nagios/nagios_epel.pp
libsepol.print_missing_requirements: nagios_epel's global requirements were not met: type/attribute nagios_script_t (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
semodule:  Failed!
Comment 1 Stephen John Smoogen 2017-07-26 13:38:48 EDT
Thank you for catching this blatantly silly mistake on my part.
Comment 2 Fedora Update System 2017-07-26 13:48:12 EDT
nagios-4.3.2-9.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-42b05795fd
Comment 3 Fred Wittekind IV 2017-07-26 14:01:58 EDT
# rpm --erase nagios-selinux
nagios_epel not found
# rpm -U nagios-4.3.2-9.el6.x86_64.rpm nagios-common-4.3.2-9.el6.x86_64.rpm
# rpm -i nagios-selinux-4.3.2-9.el6.x86_64.rpm
# semodule -l |grep nagios
nagios  1.8.0
# semodule -i /usr/share/selinux/packages/nagios/nagios_epel.pp
libsepol.print_missing_requirements: nagios_epel's global requirements were not met: type/attribute nagios_script_t (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
semodule:  Failed!


1/2 issues fixed...
Comment 4 Fedora Update System 2017-07-26 15:36:33 EDT
nagios-4.3.2-10.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-e7a6090e6c
Comment 5 Stephen John Smoogen 2017-07-26 15:39:22 EDT
Root cause analysis:
1. Tested on existing system with prebuilt selinux module
2. Forgot to remove prebuilt

Fixes:
1. Spin up fresh EL6 and EL7 systems
2. Test on those before doing fedpkg update
Comment 6 Fred Wittekind IV 2017-07-26 15:54:46 EDT
# rpm --erase nagios-selinux
# rpm -U nagios-4.3.2-10.el6.x86_64.rpm nagios-common-4.3.2-10.el6.x86_64.rpm
# rpm -i nagios-selinux-4.3.2-10.el6.x86_64.rpm
# semodule -l |grep nagios
nagios  1.8.0
nagios_epel     1.1

Looks like a fix to me.
Comment 7 Fred Wittekind IV 2017-07-26 16:00:50 EDT
New issue
# service nagios start
Starting nagios:mktemp: too few X's in template `/var/log/nagios/nagios.configtest.xxx'
/etc/init.d/nagios: line 96: : No such file or directory
grep: : No such file or directory
grep: : No such file or directory
egrep: : No such file or directory
cat: : No such file or directory
Comment 8 Fedora Update System 2017-07-26 16:41:41 EDT
nagios-4.3.2-11.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-7f9225bb51
Comment 9 Fred Wittekind IV 2017-07-26 16:49:23 EDT
That one seems to fix it.
Comment 10 Fedora Update System 2017-07-27 23:17:18 EDT
nagios-4.3.2-11.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-7f9225bb51
Comment 11 Fedora Update System 2017-10-02 15:12:35 EDT
nagios-4.3.4-3.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-170150faa2
Comment 12 Fedora Update System 2017-10-05 22:48:24 EDT
nagios-4.3.4-3.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-170150faa2
Comment 13 Fedora Update System 2017-11-16 11:53:12 EST
nagios-4.3.4-4.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.