Bug 147547 - cannot connect to a server - localhost port 5432
cannot connect to a server - localhost port 5432
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pgadmin3 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils O. Selåsdal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-08 22:01 EST by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-28 22:15:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this is the ~/pgadmin.log (1.86 KB, text/plain)
2005-02-08 22:43 EST, Jim Cornette
no flags Details
could not edit logging level with program tool .pgadmin3 (620 bytes, text/plain)
2005-02-08 22:58 EST, Jim Cornette
no flags Details
After enabling debugging logging -pgadmin.log (15.52 KB, text/plain)
2005-02-08 23:07 EST, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2005-02-08 22:01:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20050122 Fedora/1.7.5-3

Description of problem:
When trying to connect to a server via file -> add server, I get an
error stating the below response.
An Error occurred:
Is the host running on 127.0.0.1 and accepting TCP/IP connections on
port 5342?
I tried with adding port 5432 to the firewall rules, stopping iptables
and disabling selinux, none of the changes improved the situation.
I am able to createdb <database> and to psql <database> with success.
I cannot connect through this program though. The same user is
selected where there is an actual database.
I tried this on another computer and had the sam results as indicated
above.

Version-Release number of selected component (if applicable):
pgadmin3-1.0.2-3, postgresql-7.4.7-1.FC3.2, wxGTK2-2.4.2-7,
wxGTK2-stc-2.4.2-7
wxGTK2-xrc-2.4.2-7
wxGTK-common-2.4.2-7

How reproducible:
Always

Steps to Reproduce:
1. Start pgadmin3
2. try to connect to server
3. get error as described above
    

Actual Results:  most menu choices were blank, no servers identified
in right pane. Could not connect to an existing databae or postgres
server in general. I could create or manipulate the database thrugh a
command shell

Expected Results:  Expected to be able to connect to the server and
work with or create database and be able to change the properties of
the DB

Additional info:

This is the first time that I have tried this program out. I have used
rhdb before with moderate success. The system defaults are the
configuration settings, only a user and database created by the user
were performed.
Comment 1 Jim Cornette 2005-02-08 22:43:29 EST
Created attachment 110845 [details]
this is the ~/pgadmin.log

In case this shows errors as to wgy I cannot connect to the server, here it is!
Comment 2 Jim Cornette 2005-02-08 22:58:29 EST
Created attachment 110847 [details]
could not edit logging level with program tool .pgadmin3

Using the GUI menu choice, I could not change my logging level to allow
debugging mode to log. I was able to change the entry with an editor. The
problem is that you select the debugging button on the GUI program. When you
click on the OK button, nothing happens.
Comment 3 Jim Cornette 2005-02-08 23:07:29 EST
Created attachment 110850 [details]
After enabling debugging logging -pgadmin.log

After manually changing the logging options with a test editor, I tried to
connect to the server, then change the logging options. This is the logging
with debugging enbled.
Strange enough, the button selection and pressing OK works now, after the
manual entry change.
Comment 4 Jim Cornette 2005-02-09 12:11:22 EST
Referencing this message, the problem is related to TCP/IP socets being set to
false in reference to the message listed below.

https://www.redhat.com/archives/fedora-list/2004-January/msg05652.html

The program seems to react as postgresql does now when trying to use tcp/ip.
Comment 5 Jim Cornette 2005-02-09 12:30:51 EST
You also need to edit pg_hba.conf file to add 127.0.0.1 or your specific IP
address and netmask.
The program is working now, but not initially.

A helpful solution would be to change the error message to point to checking if
postgresql.conf has tcpip_socket set to = true. and you have a pg_hda.conf file
allowing your localhost or IP address information set.
Comment 6 Michael Schwendt 2005-02-24 03:21:41 EST
[package owner's e-mail address gives 550 user unknown - reassigning to
extras-orphan]

Note You need to log in before you can comment on or make changes to this bug.