Bug 1475526 - Modify the PXELinux global default provisioning template to have the additional capability to PXE boot a system to rescue mode
Modify the PXELinux global default provisioning template to have the addition...
Status: CLOSED CANTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning Templates (Show other bugs)
Unspecified
x86_64 Linux
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-26 16:37 EDT by Ross Bram
Modified: 2018-01-19 09:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-19 09:37:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ross Bram 2017-07-26 16:37:33 EDT
Description of problem:


Version-Release number of selected component (if applicable):

Due to a power hit, one EL 7 system shows grub errors and doesn't boot.  I would like to preserve the existing partitions on this system, therefore I do not want to re-provision it.  I am requesting a modification to the Satellite server's PXELinux global default provisioning template (or create a separate rescue template) so I may PXE boot this system to rescue mode and troubleshoot the boot issue.


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Lukas Zapletal 2018-01-19 09:37:51 EST
Ross,

PXELinux "local boot" template managed by Satellite directly boots from local drive. It does read MBR record and hands over to OS boot loader. In other words, it is not possible to tell which entry you want to boot. Here are the relevant bits:

https://github.com/theforeman/community-templates/blob/develop/provisioning_templates/PXELinux/pxelinux_default_local_boot.erb

https://github.com/theforeman/community-templates/blob/develop/provisioning_templates/snippet/pxelinux_chainload.erb

What you want is technically possible, but you would need to create separate partition with rescue kernel/initeramdisk and boot from that volume. In this case, this is not good candidate for shipping by default.

I am going to close your request, feel free to reopen and provide more details how technically you would like this to work.

Note You need to log in before you can comment on or make changes to this bug.