Bug 1475573 - Python xlrd 1.0.0 is available
Summary: Python xlrd 1.0.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-xlrd
Version: 26
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jan ONDREJ
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-26 23:09 UTC by dan.cermak
Modified: 2017-09-06 20:51 UTC (History)
4 users (show)

Fixed In Version: python-xlrd-1.0.0-6.el7 python-xlrd-1.0.0-6.fc26 python-xlrd-1.0.0-6.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-18 01:21:17 UTC


Attachments (Terms of Use)
spec file for python-xlrd 1.0.0 & EL 6 & EL7 (7.58 KB, text/x-matlab)
2017-07-26 23:09 UTC, dan.cermak
no flags Details

Description dan.cermak 2017-07-26 23:09:29 UTC
Created attachment 1305083 [details]
spec file for python-xlrd 1.0.0 & EL 6 & EL7

Description of problem:
A newer version of python-xlrd is available.

Version-Release number of selected component (if applicable):
Installed: 0.9.4-5.fc26
Available: 1.0.0

How reproducible:
always

Steps to Reproduce:
1. Install python3/2-xlrd
2. dnf info python3-xlrd|grep version

Actual results:
Version      : 0.9.4

Expected results:
Version      : 1.0.0

Additional info:
I have updated the spec file to version 1.0.0 and also changed the macros to enable builds for EL6 & EL7. The updated spec file is attached. I have also tested the new version on copr: https://copr.fedorainfracloud.org/coprs/defolos/devel/build/583876/.

Hope this helps.

Comment 1 Jan ONDREJ 2017-07-28 11:03:35 UTC
Is this version compatible with current el6 version 0.6.x)?
Can I release it for el6 too, or only for Fedora and EPEL7?

Comment 2 dan.cermak 2017-07-28 11:55:23 UTC
Sorry, I don't know that. I don't personally use xlrd, I just packaged the most recent version to use it with odoo on CentOS 7. I have glanced over the history file and it does not mention any breaking changes. However, the git log between 1.0.0 and 0.6 is really huge, so I am unsure whether they are actually compatible.

I can try to ask the maintainers, maybe they'll know.

Comment 3 Jan ONDREJ 2017-08-01 11:11:57 UTC
Version 1.0.0 has been built for Fedora 27 and EPEL7.
Asking author, if I can release update for other systems.

Comment 4 Fedora Update System 2017-08-01 11:13:41 UTC
python-xlrd-1.0.0-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-28628969d0

Comment 5 Fedora Update System 2017-08-01 22:19:27 UTC
python-xlrd-1.0.0-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-28628969d0

Comment 6 Fedora Update System 2017-08-12 01:29:14 UTC
python-xlrd-1.0.0-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-76b2ca627c

Comment 7 Jan ONDREJ 2017-08-12 07:24:24 UTC
Reply form author:

From: Chris Withers <chris@simplistix.co.uk>                                    
Date: Thu, 3 Aug 2017 06:47:00 +0100                                            
Cc: John Machin <sjmachin@lexicon.net>, dan.cermak@cgc-instruments.com          
Subject: Re: Fwd: Python-xlrd 1.X compatibility                                 

Hi Jan,

It's certainly intended that 1.0 is fully compatible with older versions.

I will note that xlrd, like the xls format, is also somewhat end of life. If
you have a specific read to need .xls files (rather than .xlsx), then xlrd is   
still there, but I'd generally recommend people use openpyxl instead now.

cheers,

Chris

----------------------------------------------------

Pushing python-xlrd-1.0.0 for Fedora 26 and 25 too.
Not planned to release is for EL6, only if somebody really needs it.

Comment 8 Fedora Update System 2017-08-13 04:05:45 UTC
python-xlrd-1.0.0-6.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3912496210

Comment 9 Fedora Update System 2017-08-18 01:21:17 UTC
python-xlrd-1.0.0-6.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-09-06 14:52:15 UTC
python-xlrd-1.0.0-6.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2017-09-06 20:51:47 UTC
python-xlrd-1.0.0-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.