Bug 147559 - compilation of mc in non-UTF8 environment
Summary: compilation of mc in non-UTF8 environment
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 143415
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-09 09:19 UTC by Andy Shevchenko
Modified: 2013-07-02 23:06 UTC (History)
2 users (show)

Fixed In Version: 4.6.1a-0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-17 14:07:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logo patch fix. (431 bytes, patch)
2005-02-09 09:21 UTC, Andy Shevchenko
no flags Details | Diff

Description Andy Shevchenko 2005-02-09 09:19:34 UTC
Description of problem:
The logo patch shipped in last mc update is broken in non-UTF8 
compile-time environment (such slang).
acs_map table is not present in non-UTf8 slang.

Actual results:
No success compilation.

Please, see attached fix.

Comment 1 Andy Shevchenko 2005-02-09 09:21:41 UTC
Created attachment 110861 [details]
logo patch fix.

Comment 2 Dmitry Butskoy 2005-02-09 10:58:26 UTC
  Fedora Core 3 already has utf8-patched system slang, there is no any
other "slang" in official distribution.
  What version of slang did you use for compile MC?

Comment 3 Jindrich Novy 2005-02-09 11:37:52 UTC
Hello Andy,

there wouldn't occur any problems while compiling mc on FC3, because
it  prefers a dependency on libslang-utf8.so than on libslang.so. This
is because a rejection of system slang with UTF-8 support, which I
commented out. (see the last hunk of the mc-utf8.patch)

However, a prevention of acs_map usage with non-UTF8 slang is good to
keep the utf8 patch portable so I'll apply it.

thanks,
Jindrich

Comment 4 Jindrich Novy 2005-02-09 12:09:53 UTC
It's now applied.

Comment 5 Andy Shevchenko 2005-02-10 08:57:42 UTC
2Dmitry: I try to compile new mc on system similar to RHEL2.1as.

Yes, of course. This is portable to non-UTF8 systems issue.

Thank you, Jindrich.


P.S> I had seen the patch attached to bug #143415, but it not solves 
my problem.


Note You need to log in before you can comment on or make changes to this bug.