Bug 1475662 - [Scale] : Rebalance Logs are bulky.
[Scale] : Rebalance Logs are bulky.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
3.12
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Susant Kumar Palai
:
Depends On: 1473259 1474639
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 02:31 EDT by Susant Kumar Palai
Modified: 2017-10-26 10:35 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1474639
Environment:
Last Closed: 2017-09-05 13:37:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Worker Ant 2017-07-27 02:53:24 EDT
REVIEW: https://review.gluster.org/17893 (cluster/dht: change log level to debug for thread activity) posted (#1) for review on release-3.12 by Susant Palai (spalai@redhat.com)
Comment 2 Worker Ant 2017-07-31 12:30:40 EDT
COMMIT: https://review.gluster.org/17893 committed in release-3.12 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 332d553cb8eba208fe421723b64f8c19b43fd696
Author: Susant Palai <spalai@redhat.com>
Date:   Tue Jul 25 11:43:37 2017 +0530

    cluster/dht: change log level to debug for thread activity
    
      Every time all the thread sleeps or wakes up, we log a message
    about that event. Sometime this can be noisy where the number of
    files eligible to be migrated are placed far away from each other.
    
    Moving the logs to DEBUG.
    
    > Change-Id: I4dc2cc9fdf4f42d4001754532a5bc4aeb3f0f959
    > BUG: 1474639
    > Signed-off-by: Susant Palai <spalai@redhat.com>
    > Reviewed-on: https://review.gluster.org/17866
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Amar Tumballi <amarts@redhat.com>
    > Reviewed-by: N Balachandran <nbalacha@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Signed-off-by: Susant Palai <spalai@redhat.com>
    
    Change-Id: I4dc2cc9fdf4f42d4001754532a5bc4aeb3f0f959
    BUG: 1475662
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: https://review.gluster.org/17893
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
Comment 3 Shyamsundar 2017-09-05 13:37:48 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.