Bug 1475695 - error during connect: Post http://%2Fvar%2Frun%2Fdocker.sock/v1.26/containers/create: EOF
error during connect: Post http://%2Fvar%2Frun%2Fdocker.sock/v1.26/containers...
Status: CLOSED DUPLICATE of bug 1474752
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Antonio Murdaca
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 03:49 EDT by Lukas Slebodnik
Modified: 2017-07-27 06:38 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 06:38:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Slebodnik 2017-07-27 03:49:43 EDT
Description of problem:
The latest upgrade of docker in rawhide broke starting of containers 

Version-Release number of selected component (if applicable):
sh$ rpm -q docker
docker-1.13.1-22.git27e468e.fc27.x86_64

How reproducible:
Always

Steps to Reproduce:
1. docker run -ti --rm docker.io/fedora:25 bash

Actual results:
/usr/bin/docker-current: error during connect: Post http://%2Fvar%2Frun%2Fdocker.sock/v1.26/containers/create: EOF.
See '/usr/bin/docker-current run --help'.

Expected results:
Container is created without any error

Additional info:
Output from journald

Jul 27 09:47:33 dockerd-current[15633]: http: panic serving @: reflect: call of reflect.Value.Int on zero Value
                                        goroutine 44 [running]:
                                        net/http.(*conn).serve.func1(0xc420ec0000)
                                                /usr/lib/golang/src/net/http/server.go:1693 +0xd0
                                        panic(0x1719220, 0xc420c78120)
                                                /usr/lib/golang/src/runtime/panic.go:491 +0x283
                                        reflect.Value.Int(0x0, 0x0, 0x0, 0x198c4be)
                                                /usr/lib/golang/src/reflect/value.go:908 +0x141
                                        github.com/docker/docker/api/server/middleware.getFdFromWriter(0x25dcb20, 0xc4203580e0, 0xc420e74525)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/middleware/audit_linux.go:86 +0x403
                                        github.com/docker/docker/api/server/middleware.logAction(0x25dcb20, 0xc4203580e0, 0xc420342200, 0xc4204b4000, 0xc420342200, 0x1694380)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/middleware/audit_linux.go:212 +0xe2
                                        github.com/docker/docker/api/server/middleware.AuditMiddleware.WrapHandler.func1(0x25e04a0, 0xc420ce0090, 0x25dcb20, 0xc4203580e0, 0xc420342200, 0xc420ce0000, 0xc420ec8b38, 0x483cbe)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/middleware/audit_linux.go:26 +0x55
                                        github.com/docker/docker/api/server.(*Server).makeHTTPHandler.func1(0x25dcb20, 0xc4203580e0, 0xc420342200)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/server.go:146 +0x1e5
                                        net/http.HandlerFunc.ServeHTTP(0xc420afdd60, 0x25dcb20, 0xc4203580e0, 0xc420342200)
                                                /usr/lib/golang/src/net/http/server.go:1914 +0x44
                                        github.com/docker/docker/vendor/github.com/gorilla/mux.(*Router).ServeHTTP(0xc420611cc0, 0x25dcb20, 0xc4203580e0, 0xc420342200)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/vendor/github.com/gorilla/mux/mux.go:103 +0x22b
                                        github.com/docker/docker/api/server.(*routerSwapper).ServeHTTP(0xc420e0b230, 0x25dcb20, 0xc4203580e0, 0xc420342200)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/router_swapper.go:29 +0x70
                                        net/http.serverHandler.ServeHTTP(0xc420326410, 0x25dcb20, 0xc4203580e0, 0xc420342200)
                                                /usr/lib/golang/src/net/http/server.go:2610 +0xb4
                                        net/http.(*conn).serve(0xc420ec0000, 0x25de7a0, 0xc420ea7440)
                                                /usr/lib/golang/src/net/http/server.go:1797 +0x71d
                                        created by net/http.(*Server).Serve
                                                /usr/lib/golang/src/net/http/server.go:2711 +0x288

Jul 27 09:47:33 dockerd-current[15633]: http: panic serving @: reflect: call of reflect.Value.Int on zero Value
                                        goroutine 112 [running]:
                                        net/http.(*conn).serve.func1(0xc4208fc3c0)
                                                /usr/lib/golang/src/net/http/server.go:1693 +0xd0
                                        panic(0x1719220, 0xc420c78440)
                                                /usr/lib/golang/src/runtime/panic.go:491 +0x283
                                        reflect.Value.Int(0x0, 0x0, 0x0, 0x198c4be)
                                                /usr/lib/golang/src/reflect/value.go:908 +0x141
                                        github.com/docker/docker/api/server/middleware.getFdFromWriter(0x25dcb20, 0xc420358380, 0xc420ed0857)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/middleware/audit_linux.go:86 +0x403
                                        github.com/docker/docker/api/server/middleware.logAction(0x25dcb20, 0xc420358380, 0xc420342b00, 0xc4204b4000, 0xc420342b00, 0x1694380)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/middleware/audit_linux.go:212 +0xe2
                                        github.com/docker/docker/api/server/middleware.AuditMiddleware.WrapHandler.func1(0x25e04a0, 0xc420ce0750, 0x25dcb20, 0xc420358380, 0xc420342b00, 0xc420ce0600, 0xc420ec8b38, 0x483cbe)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/middleware/audit_linux.go:26 +0x55
                                        github.com/docker/docker/api/server.(*Server).makeHTTPHandler.func1(0x25dcb20, 0xc420358380, 0xc420342b00)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/server.go:146 +0x1e5
                                        net/http.HandlerFunc.ServeHTTP(0xc4204b70c0, 0x25dcb20, 0xc420358380, 0xc420342b00)
                                                /usr/lib/golang/src/net/http/server.go:1914 +0x44
                                        github.com/docker/docker/vendor/github.com/gorilla/mux.(*Router).ServeHTTP(0xc420611cc0, 0x25dcb20, 0xc420358380, 0xc420342b00)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/vendor/github.com/gorilla/mux/mux.go:103 +0x22b
                                        github.com/docker/docker/api/server.(*routerSwapper).ServeHTTP(0xc420e0b230, 0x25dcb20, 0xc420358380, 0xc420342b00)
                                                /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/router_swapper.go:29 +0x70
                                        net/http.serverHandler.ServeHTTP(0xc420326410, 0x25dcb20, 0xc420358380, 0xc420342b00)
                                                /usr/lib/golang/src/net/http/server.go:2610 +0xb4
                                        net/http.(*conn).serve(0xc4208fc3c0, 0x25de7a0, 0xc420cd40c0)
                                                /usr/lib/golang/src/net/http/server.go:1797 +0x71d
                                        created by net/http.(*Server).Serve
                                                /usr/lib/golang/src/net/http/server.go:2711 +0x288
Comment 1 Lukas Slebodnik 2017-07-27 03:58:52 EDT
Following packages does not work either

sh# rpm -qa | grep 1.13.1-21.git27e468e.fc27
docker-1.13.1-21.git27e468e.fc27.x86_64
oci-umount-1.13.1-21.git27e468e.fc27.x86_64
docker-common-1.13.1-21.git27e468e.fc27.x86_64
docker-rhel-push-plugin-1.13.1-21.git27e468e.fc27.x86_64

I had to downgrade to -20
Comment 2 Antonio Murdaca 2017-07-27 06:38:19 EDT

*** This bug has been marked as a duplicate of bug 1474752 ***

Note You need to log in before you can comment on or make changes to this bug.