Bug 1475708 - (CVE-2017-11638) CVE-2017-11638 GraphicsMagick: Segmentation violation in the WriteMAPImage() function
CVE-2017-11638 GraphicsMagick: Segmentation violation in the WriteMAPImage() ...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
impact=low,public=20170722,reported=2...
: Security
Depends On: 1475494 1475495
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 04:11 EDT by Andrej Nemec
Modified: 2017-07-27 04:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Nemec 2017-07-27 04:11:39 EDT
GraphicsMagick 1.3.26 has a segmentation violation in the WriteMAPImage() function in coders/map.c when processing a non-colormapped image, a different vulnerability than CVE-2017-11642.

Upstream patch:

http://hg.code.sf.net/p/graphicsmagick/code/rev/29550606d8b9
Comment 1 Andrej Nemec 2017-07-27 04:12:25 EDT
Created GraphicsMagick tracking bugs for this issue:

Affects: epel-all [bug 1475494]
Affects: fedora-all [bug 1475495]

Note You need to log in before you can comment on or make changes to this bug.