Bug 1475712 - Pass TSP IPs to gluster block and let gluster-block take the call of selecting the node.
Pass TSP IPs to gluster block and let gluster-block take the call of selectin...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Adam
krishnaram Karthick
:
Depends On:
Blocks: 1445448
  Show dependency treegraph
 
Reported: 2017-07-27 04:16 EDT by Humble Chirammal
Modified: 2017-08-08 00:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 07:50:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Humble Chirammal 2017-07-27 04:16:14 EDT
Description of problem:




[root@master ~]# heketi-cli blockvolume create --ha=1 --size=1
Error: Unable to execute command on glusterfs-6qz73:

[root@master ~]# oc logs heketi-1-22x5g |tail -f
[kubeexec] ERROR 2017/07/27 08:07:42 /src/github.com/heketi/heketi/executors/kubeexec/kubeexec.go:247: Failed to run command [gluster-block create vol_96d8648ebd2ff7dcb87be3a2587c6246/blockvol_d05194476743bbccee6ff5cc61459bdd  ha 1 auth disable  192.168.35.3 1G --json] .......

The problem is that when it the request is  "ha 1", it send only one IP to gluster block.


As discussed earlier let heketi send the TSP IPs and let gluster block do the selection based on ha value.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Note You need to log in before you can comment on or make changes to this bug.