Bug 1475747 - Return error message when hotplug one cpu core with setting core-id to a negative number
Return error message when hotplug one cpu core with setting core-id to a nega...
Status: CLOSED DUPLICATE of bug 1476181
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.4-Alt
ppc64le Unspecified
medium Severity medium
: rc
: ---
Assigned To: David Gibson
Xujun Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 05:06 EDT by Xujun Ma
Modified: 2017-08-02 06:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 06:36:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xujun Ma 2017-07-27 05:06:20 EDT
Description of problem:
Return error message when hotplug one cpu core with setting core-id to a negative number

Version-Release number of selected component (if applicable):
host:4.11.0-10.el7a.ppc64le
guest:4.11.0-16.el7a.ppc64le
qemu:qemu-kvm-2.9.0-18.el7a.ppc64le

How reproducible:
100%

Steps to Reproduce:
1.Boot guest with command
/usr/libexec/qemu-kvm \
 -name vm \
 -m 8192 \
 -rtc base=utc,clock=host \
 -smp 2,maxcpus=4,cores=4,threads=1,sockets=1 \
 -chardev stdio,mux=on,id=serial_id_serial0,server,nowait \
 -device spapr-vty,id=serial111,chardev=serial_id_serial0 \
 -mon chardev=serial_id_serial0,mode=readline \
 -nodefaults \
 -device virtio-scsi-pci,bus=pci.0,addr=0x5 \
 -device scsi-hd,id=scsi-hd0,drive=scsi-hd-dr0,bootindex=1\
 -drive file=pegas.qcow2,if=none,id=scsi-hd-dr0,format=qcow2,cache=none \
 -device virtio-net-pci,netdev=net0,id=nic0,mac=70:e2:84:14:e7:84 \
 -netdev tap,id=net0,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown,vhost=on 
2.Hotplug cpu core
(qemu) device_add host-spapr-cpu-core,core-id=-1,id=core
3.

Actual results:
(qemu) device_add host-spapr-cpu-core,core-id=-1,id=core
core -1 already populated


Expected results:
core id is invalid.

Additional info:

same issue on power8
Comment 2 Laurent Vivier 2017-08-02 06:36:02 EDT
Set as a duplicate of 1476181 as the cause is the same (negative core id) and the fix will be the same: don't allow negative core id.

*** This bug has been marked as a duplicate of bug 1476181 ***

Note You need to log in before you can comment on or make changes to this bug.