Bug 1475751 - migration/RDMA: backport fixes
migration/RDMA: backport fixes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.4-Alt
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dr. David Alan Gilbert
xianwang
:
Depends On: 1285044 1457423
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 05:15 EDT by Dr. David Alan Gilbert
Modified: 2017-11-09 06:31 EST (History)
14 users (show)

See Also:
Fixed In Version: qemu-kvm-2.9.0-19.el7a
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1285044
Environment:
Last Closed: 2017-11-09 06:31:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3169 normal SHIPPED_LIVE qemu-kvm enhancement update 2017-11-09 11:13:13 EST

  None (edit)
Comment 2 Dr. David Alan Gilbert 2017-07-27 08:10:40 EDT
Posted downstream.

Note, the easiest case to test that this fixes is:
   a) Start qemu on destination
   b) Start qemu on source
   c) Start migration (migrate -d)
   d) Kill qemu on destination before migration finishes
   e) do  migrate_cancel on source
   f) Use   'info migrate' to check the source isn't stuck in cancelling.

You have to be pretty fast to do (d) unless you give the guest lots of RAM.
Comment 3 Miroslav Rezanina 2017-08-01 09:34:47 EDT
Fix included in qemu-kvm-2.9.0-19.el7a
Comment 5 Qunfang Zhang 2017-09-08 04:11:40 EDT
Currently we are still waiting for the second DD2 hardware to test migration, and confirming with IBM when the second DD2 hardware is available for QE.
Comment 6 xianwang 2017-09-19 04:09:18 EDT
 (In reply to Dr. David Alan Gilbert from comment #2)
> Posted downstream.
> 
> Note, the easiest case to test that this fixes is:
>    a) Start qemu on destination
>    b) Start qemu on source
>    c) Start migration (migrate -d)
>    d) Kill qemu on destination before migration finishes
>    e) do  migrate_cancel on source
>    f) Use   'info migrate' to check the source isn't stuck in cancelling.
> 
> You have to be pretty fast to do (d) unless you give the guest lots of RAM.

I have test this scenario on P9 DD2, the result of step f) is "Migration status: cancelled", but once I "migrate_cancel" in src host, there will be "(qemu) qemu-kvm: Early error. Sending error." prompt in src HMP, the vm works well, I am not sure whether it is expected result.

version:
host:
4.11.0-33.el7a.ppc64le
qemu-kvm-2.9.0-22.el7a.ppc64le
SLOF-20170303-4.git66d250e.el7.noarch

guest:
4.11.0-33.el7a.ppc64le

scenario I:
step:
 Start qemu on destination
    b) Start qemu on source
    c) Start migration (migrate -d)
    d) Kill qemu on destination before migration finishes
    e) do  migrate_cancel on source
    f) Use   'info migrate' to check the source isn't stuck in cancelling.
result:
src:
(qemu) migrate_cancel 
(qemu) qemu-kvm: rdma migration: recv polling control error!
qemu-kvm: RDMA is in an error state waiting migration to abort!
qemu-kvm: Early error. Sending error.
qemu-kvm: rdma migration: send polling control error
(qemu) info migrate
capabilities: xbzrle: off rdma-pin-all: on auto-converge: off zero-blocks: off compress: off events: off postcopy-ram: off x-colo: off release-ram: off 
Migration status: cancelled
total time: 0 milliseconds
(qemu) info status 
VM status: running

vm works well in src host.

scenario II:
step:
 Start qemu on destination
    b) Start qemu on source
    c) Start migration (migrate -d)
    d) do  migrate_cancel on source
    e) Use   'info migrate' to check the source isn't stuck in cancelling.
result:
(qemu) migrate_cancel 
(qemu) qemu-kvm: Early error. Sending error.
(qemu) info migrate
capabilities: xbzrle: off rdma-pin-all: on auto-converge: off zero-blocks: off compress: off events: off postcopy-ram: off x-colo: off release-ram: off 
Migration status: cancelled
total time: 0 milliseconds
(qemu) info status 
VM status: running

vm works well in src host.
Comment 7 Dr. David Alan Gilbert 2017-09-19 04:31:16 EDT
Yes, that's fine - the important thing is that the source carries on working and the monitor on the source responds to commands (such as the info).
Comment 8 xianwang 2017-09-19 06:38:52 EDT
ok, referring to comment2,6,7,this bug is fixed.
Comment 10 errata-xmlrpc 2017-11-09 06:31:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3169

Note You need to log in before you can comment on or make changes to this bug.