Bug 1475761 - [3.6] Installer failed on logging deployment on the second run
[3.6] Installer failed on logging deployment on the second run
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.6.z
Assigned To: ewolinet
Gaoyun Pei
:
: 1481125 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 05:33 EDT by Gaoyun Pei
Modified: 2017-09-05 13:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: If a pvc already existed the playbook would fail trying to recreate it Consequence: The playbook would fail Fix: We no longer create a pvc object if it already exists Result: The playbook correctly completes without error
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 13:42:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Scott Dodson 2017-08-14 08:48:11 EDT
*** Bug 1481125 has been marked as a duplicate of this bug. ***
Comment 2 ewolinet 2017-08-21 12:18:06 EDT
This should have been resolved by https://github.com/openshift/openshift-ansible/pull/5005
Comment 4 Gaoyun Pei 2017-08-24 04:55:30 EDT
Verify this bug with openshift-ansible-3.6.173.0.7-2.git.0.340aa2c.el7.

No such error when running byo playbook again after installation finished.  
ansible-playbook -i inventory /usr/share/ansible/openshift-ansible/playbooks/byo/config.yml



TASK [openshift_logging_elasticsearch : Set ES configmap] *******************************************************************************************************************
ok: [ec2-52-70-115-23.compute-1.amazonaws.com]

TASK [openshift_logging_elasticsearch : Set ES secret] **********************************************************************************************************************
ok: [ec2-52-70-115-23.compute-1.amazonaws.com]

TASK [openshift_logging_elasticsearch : Set logging-es-cluster service] *****************************************************************************************************
changed: [ec2-52-70-115-23.compute-1.amazonaws.com]

TASK [openshift_logging_elasticsearch : Set logging-es service] *************************************************************************************************************
changed: [ec2-52-70-115-23.compute-1.amazonaws.com]

TASK [openshift_logging_elasticsearch : Check to see if PVC already exists] *************************************************************************************************
ok: [ec2-52-70-115-23.compute-1.amazonaws.com]

TASK [openshift_logging_elasticsearch : Creating ES storage template - static] **********************************************************************************************
skipping: [ec2-52-70-115-23.compute-1.amazonaws.com]

TASK [openshift_logging_elasticsearch : Creating ES storage template - dynamic] *********************************************************************************************
skipping: [ec2-52-70-115-23.compute-1.amazonaws.com]

TASK [openshift_logging_elasticsearch : Set ES storage] *********************************************************************************************************************
skipping: [ec2-52-70-115-23.compute-1.amazonaws.com]

TASK [openshift_logging_elasticsearch : set_fact] ***************************************************************************************************************************
skipping: [ec2-52-70-115-23.compute-1.amazonaws.com]
Comment 5 Peter Larsen 2017-08-29 11:04:19 EDT
From chat with sdodson I applied this patch and successfully was able to test the run. The error I was getting before the patch:

TASK [openshift_logging_elasticsearch : Creating ES storage template - dynamic] ********************************************************************************************
 [WARNING]: when statements should not include jinja2 templating delimiters such as {{ }} or {% %}. Found: {{ openshift_logging_es_pvc_dynamic }}
 
The package I was running before the update was openshift-ansible-3.6.173.0.5-3.git....
Comment 7 errata-xmlrpc 2017-09-05 13:42:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2639

Note You need to log in before you can comment on or make changes to this bug.