Bug 1475762 - malformed address in route printed by 'ip route list' for RTN_MULTICAST type and AF_INET family
malformed address in route printed by 'ip route list' for RTN_MULTICAST type ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: iproute (Show other bugs)
7.4-Alt
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Stefano Brivio
Jaroslav Aster
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 05:33 EDT by Stefano Brivio
Modified: 2018-04-10 10:31 EDT (History)
4 users (show)

See Also:
Fixed In Version: iproute-4.11.0-6.el7
Doc Type: Bug Fix
Doc Text:
Cause: Due to insufficient checks IPv4 multicast route addresses were incorrectly treated as IPv6 ones. Consequence: Listing IPv4 multicast routes showed malformed addresses. Fix: Affected code has been corrected. Result: Listing IPv4 multicast routes now correctly shows IPv4 addresses.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 10:31:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch as submitted to maintainer (1.87 KB, patch)
2017-07-27 16:00 EDT, Stefano Brivio
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0815 None None None 2018-04-10 10:31 EDT

  None (edit)
Description Stefano Brivio 2017-07-27 05:33:56 EDT
Found in CI test run at:

    https://beaker.engineering.redhat.com/jobs/1973898

in test:

	Task: (Fail) /kernel/networking/route/route_func - STANDALONE, TEST_TYPE=netns, TEST_TOPO=default, ROUTE_MODE=local
	test: (Fail) Route-Selector-netns-default-local

---

Add a IPv4 multicast route:
    ip -4 route add multicast 172.111.1.1 dev veth1 table main

and list it:
    ip -4 route list type multicast table main

we get:
    multicast ac6f:101:800:400:400:0:3c00:0 dev veth1 scope link

instead of the expected:
    multicast 172.111.1.1 dev veth1 scope link
Comment 2 Stefano Brivio 2017-07-27 16:00 EDT
Created attachment 1305641 [details]
Patch as submitted to maintainer
Comment 3 Phil Sutter 2017-09-07 13:34:27 EDT
Postponing this to RHEL-7.5.
Comment 8 errata-xmlrpc 2018-04-10 10:31:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0815

Note You need to log in before you can comment on or make changes to this bug.