Bug 1475788 - engine-cleanup renames conf files of postgres
engine-cleanup renames conf files of postgres
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Setup.Engine (Show other bugs)
4.2.0
All All
medium Severity medium (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Yedidyah Bar David
David Necpal
:
: 1456727 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 07:25 EDT by Lukas Svaty
Modified: 2017-12-20 05:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:48:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79902 master MERGED Revert "packaging: setup: Add to unremovable only files we wrote" 2017-08-03 03:54 EDT

  None (edit)
Description Lukas Svaty 2017-07-27 07:25:38 EDT
Description of problem:
Engine-cleanup utility moves postgres conf files to backup files with timestamps. However without these files postgres is unable to start. Thus process of engine-cleanup && engine-setup needs manual intervention of creating new conf files.
These files should either be just copied to bakcups, if possible even backed up to original state before engine was installed.

Version-Release number of selected component (if applicable):
otopi-1.7.2-0.0.master.20170725102025.git770a428.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. run engine-cleanup
2. try to run engine-setup (fails on database conf files missing)
3.  mv /var/lib/pgsql/data/postgresql.conf.20170725150124 /var/lib/pgsql/data/postgresql.conf
4. mv /var/lib/pgsql/data/pg_hba.conf.20170725150124 /var/lib/pgsql/data/pg_hba.conf
5. run engine setup -> success

Actual results:
Need manual creation of new conf files.

Expected results:
These conf files should be 
a) on engine-setup created by engine setup not just edited
or
b) on engine-cleanup copied not moved to backup
or
c) on engine-cleanup restored from backup of conf files created by engine-setup  

Additional info:
Comment 1 David Necpal 2017-09-04 12:29:51 EDT
Verified on version:
otopi-1.7.2-0.0.master.20170816071636.git7a3278c.el7.centos.noarch

engine-cleanup create copy of config file
Comment 2 Yedidyah Bar David 2017-10-18 04:41:15 EDT
*** Bug 1456727 has been marked as a duplicate of this bug. ***
Comment 3 Sandro Bonazzola 2017-12-20 05:48:42 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.