Bug 1475836 - (CVE-2017-9740) CVE-2017-9740 ghostscript: Heap-buffer over-read in the xps_decode_font_char_imp function
CVE-2017-9740 ghostscript: Heap-buffer over-read in the xps_decode_font_char_...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
impact=low,public=20170615,reported=2...
: Security
Depends On: 1475838
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 08:56 EDT by Andrej Nemec
Modified: 2017-07-27 09:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Nemec 2017-07-27 08:56:04 EDT
The xps_decode_font_char_imp function in xps/xpsfont.c in Artifex Ghostscript GhostXPS 9.22 allows attackers to cause a denial of service (heap-based buffer over-read and application crash) or possibly have unspecified other impact via a crafted document.

Upstream patch:

http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=961b10cdd71403072fb99401a45f3bef6ce53626

Upstream issue:

https://bugs.ghostscript.com/show_bug.cgi?id=698064
Comment 1 Andrej Nemec 2017-07-27 09:01:04 EDT
Created ghostscript tracking bugs for this issue:

Affects: fedora-all [bug 1475838]

Note You need to log in before you can comment on or make changes to this bug.