Bug 1475844 - SELinux is preventing gdbus from 'read' accesses on the file /home/awyatt/.local/share/icc/edid-74a96fa85f7d7ac4c13a5c00b10e5e3f.icc.
SELinux is preventing gdbus from 'read' accesses on the file /home/awyatt/.lo...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:48e53508c1185c43be4be978b5c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 09:08 EDT by Skip Wyatt
Modified: 2017-08-06 11:45 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 10:48:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Skip Wyatt 2017-07-27 09:08:43 EDT
Description of problem:
I unlocked the screen after coming back to the machine for a while, and Gnome shell had crashed leaving this message.
SELinux is preventing gdbus from 'read' accesses on the file /home/awyatt/.local/share/icc/edid-74a96fa85f7d7ac4c13a5c00b10e5e3f.icc.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/home/awyatt/.local/share/icc/edid-74a96fa85f7d7ac4c13a5c00b10e5e3f.icc default label should be icc_data_home_t.
Then you can run restorecon. The access attempt may have been stopped due to insufficient permissions to access a parent directory in which case try to change the following command accordingly.
Do
# /sbin/restorecon -v /home/awyatt/.local/share/icc/edid-74a96fa85f7d7ac4c13a5c00b10e5e3f.icc

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that gdbus should be allowed read access on the edid-74a96fa85f7d7ac4c13a5c00b10e5e3f.icc file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gdbus' --raw | audit2allow -M my-gdbus
# semodule -X 300 -i my-gdbus.pp

Additional Information:
Source Context                system_u:system_r:colord_t:s0
Target Context                unconfined_u:object_r:home_root_t:s0
Target Objects                /home/awyatt/.local/share/icc/edid-74a96fa85f7d7ac
                              4c13a5c00b10e5e3f.icc [ file ]
Source                        gdbus
Source Path                   gdbus
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.10-300.fc26.x86_64 #1 SMP Wed
                              Jul 12 17:05:39 UTC 2017 x86_64 x86_64
Alert Count                   6
First Seen                    2017-07-25 09:16:20 EDT
Last Seen                     2017-07-27 09:05:49 EDT
Local ID                      ef1a179b-41da-484c-a729-86fba05efaf5

Raw Audit Messages
type=AVC msg=audit(1501160749.544:1349): avc:  denied  { read } for  pid=1787 comm="gdbus" path="/home/awyatt/.local/share/icc/edid-74a96fa85f7d7ac4c13a5c00b10e5e3f.icc" dev="dm-3" ino=5254708 scontext=system_u:system_r:colord_t:s0 tcontext=unconfined_u:object_r:home_root_t:s0 tclass=file permissive=0


Hash: gdbus,colord_t,home_root_t,file,read


Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.10-300.fc26.x86_64
type:           libreport

Potential duplicate: bug 1341234
Comment 1 Miroslav Grepl 2017-07-31 10:48:01 EDT
Do you know when it happened? A fresh install? An upgrade?

It is a mislabeling which can be fixed by 

# /sbin/restorecon -v /home/awyatt/.local/share/icc/edid-74a96fa85f7d7ac4c13a5c00b10e5e3f.icc
Comment 2 Skip Wyatt 2017-07-31 11:13:39 EDT
It was an upgrade from f25 -> f26.

I have perform a /sbin/restorecon -v /home/awyatt/.local/share/icc/ not just the file itself.

Note You need to log in before you can comment on or make changes to this bug.