Bug 1475874 - dnf upgrade does not remove old kernel although installonly_limit is exceeded
dnf upgrade does not remove old kernel although installonly_limit is exceeded
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
26
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 10:00 EDT by k.c.harke
Modified: 2017-07-27 10:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 10:40:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description k.c.harke 2017-07-27 10:00:40 EDT
Description of problem:
In /etc/dnf/dnf.conf installonly_limit=2 is set. Nevertheless, 3 Kernel Versions are installed.

Version-Release number of selected component (if applicable):


How reproducible:
Set installonly_limit=2 in /etc/dnf/dnf.conf
sudo dnf upgrade

Steps to Reproduce:
1.
2.
3.

Actual results:
3 installed kernel versions

Expected results:
removing kernel-4.11.8-300 ....


Additional info:
dnf list | grep kernel ->
kernel.x86_64                          4.11.8-300.fc26                 @anaconda
kernel.x86_64                          4.11.10-300.fc26                @updates 
kernel.x86_64                          4.11.11-300.fc26                @updates
Comment 1 Jaroslav Mracek 2017-07-27 10:40:11 EDT
The oldest unbooted kernel will be removed only if in transaction will be the kernel. That means if there will be new kernel update available and you will update kernel, then instead of removal 1 kernel packages, two of them will be removed. The behavior was changed, because other users did not like, that if they install something, it also removes kernels over limit. Please if I did not understand well your problem, don't hesitate to reopen the bug report.

Note You need to log in before you can comment on or make changes to this bug.