Bug 1476004 - Include the OpenDaylight container image with RHOSP 12
Include the OpenDaylight container image with RHOSP 12
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-containers (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
high Severity high
: beta
: 12.0 (Pike)
Assigned To: Jon Schlueter
Itzik Brown
: Triaged
Depends On:
Blocks: 1433895
  Show dependency treegraph
 
Reported: 2017-07-27 15:47 EDT by Nir Yechiel
Modified: 2017-12-13 14:15 EST (History)
9 users (show)

See Also:
Fixed In Version: openstack-opendaylight-docker-12.0-20170731.1 openstack-neutron-server-opendaylight-docker-12.0-20170731.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 14:15:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nir Yechiel 2017-07-27 15:47:24 EDT
Description of problem:

OpenDaylight was containerized during the Pike cycle (please refer to BZ 1433895), but purposely left out from tripleo-common because we do not want the undercloud to include OpenDaylight container by default. However, the container still needs to be available in the downstream repo so that when a customer wants to use OpenDaylight he can pull it. 

For an OpenDaylight deployment we need the OpenDaylight Controller itself, as well as Neutron server, dhcp agent and metadata agent. For Pike/RHOSP 12, the plan is to fully support OpenDaylight SDN Controller as a container, but Neutron, dhcp agent, and metadata agent will be supported as non-containerized only. Their container form should be available only as Tech Preview.

To summarize, the ask for RHOSP 12 here is to:

1) Distribute OpenDaylight container (centos-binary-opendaylight) to be fully supported

2) Distribute Neutron server container (neutron-server-opendaylight) to be offered as Tech Preview


Note: DHCP and metadata agents should already be covered by base Neutron, and are out of scope for this bug.
Comment 8 Itzik Brown 2017-09-03 02:42:37 EDT
Checked with:
openstack-opendaylight-docker:2017-08-18.2
Comment 12 errata-xmlrpc 2017-12-13 14:15:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3457

Note You need to log in before you can comment on or make changes to this bug.