This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1476012 - Release note needed for Service Catalog deprovision behavior
Release note needed for Service Catalog deprovision behavior
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alex Dellapenta
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 16:21 EDT by Erik Nelson
Modified: 2017-08-16 15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-15 14:20:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Nelson 2017-07-27 16:21:28 EDT
Describe the issue: 

When deprovisioning an APB via the service-catalog and ansible-service-broker, the "Provisioned Service" entry will linger for longer than the assets created by the APB. The Service itself will have correctly been deprovisioned.

This is due to the service catalog "eventually" confirming with the Ansible Service Broker that the service is *actually* gone.

It has been patched upstream with this PR: https://github.com/kubernetes-incubator/service-catalog/pull/1067

Additional information:

Related broker bug: https://bugzilla.redhat.com/show_bug.cgi?id=1475251
Comment 1 Alex Dellapenta 2017-07-27 16:52:54 EDT
xref'd in 3.6 release notes tracker (https://github.com/openshift/openshift-docs/issues/4021).

Note You need to log in before you can comment on or make changes to this bug.