Bug 1476057 - bootloader error during initial install
bootloader error during initial install
Status: NEW
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
26
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 20:38 EDT by Thom Carlin
Modified: 2017-07-31 09:36 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2017-07-27 20:38:18 EDT
Description of problem:

Unexpected bootloader error during initial install of Fedora 26 on HP Envy machine

Version-Release number of selected component (if applicable):

26

How reproducible:

100% with specific configuration

Steps to Reproduce:
1. Attempt to install Fedora 26 on brand new HP Envy machine

Actual results:

Anaconda errors out with bootloader error

Expected results:

Successful install

Additional info:

Background/workaround (from my memory):

I had used blivet to create a custom partition layout.

Without any real additional information, I booted into rescue mode.  Once there, I tried: grub2-install /dev/sda
Grub reported a problem with no BIOS boot being set in the GPT.  This led to a superuser.com article which mentioned gdisk.
gdisk /dev/sda
On startup, it mentioned something about a "protective MBR"
Selecting "r" brought up the "recovery and transformation options (experts only)"
Selecting "x" brought up the "extra functionality (experts only)"
Selecting "z" led to "zap (destroy) GPT data structures and exit"
Selecting "w" wrote the table to disk and exit

After that, grub2-install worked
After that, I reran anaconda with the same options.  It completed successfully and the system rebooted correctly into Fedora 26.
Comment 1 Jiri Konecny 2017-07-28 04:07:54 EDT
Hi Thom,

Could you please provides logs from the failed installation?
Comment 2 Thom Carlin 2017-07-30 15:03:25 EDT
The logs are no longer available.
Comment 3 Thom Carlin 2017-07-31 09:36:17 EDT
It would be useful if there was a way to easily do Abrt or even retrace on these types of errors.  There was network connectivity at the time of the issue.

As I recall, the only visible option was Debug to a Python debug shell.

Note You need to log in before you can comment on or make changes to this bug.