Bug 1476071 - ovirt-imageio-daemon fails to run after upgrading from 4.0 NGN (as directory "/var/log/ovirt-imageio-daemon/" is owned by user root)
ovirt-imageio-daemon fails to run after upgrading from 4.0 NGN (as directory...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-ng (Show other bugs)
4.1.1
x86_64 Linux
high Severity high
: ovirt-4.1.4-1
: ---
Assigned To: Ryan Barry
Huijuan Zhao
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 21:18 EDT by Ameya Charekar
Modified: 2017-08-11 02:33 EDT (History)
10 users (show)

See Also:
Fixed In Version: imgbased-0.9.41-0.1.el7ev
Doc Type: Bug Fix
Doc Text:
If this bug requires documentation, please select an appropriate Doc Type value.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 12:11:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80404 ovirt-4.1 MERGED osupdater: use --rbind for var 2017-08-08 10:41 EDT
oVirt gerrit 80408 master MERGED osupdater: use --rbind for var 2017-08-08 10:43 EDT

  None (edit)
Description Ameya Charekar 2017-07-27 21:18:21 EDT
Description of problem:
Issue is similar to Bug 1425502.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Upgrade to latest rhvh-4.1-0.20170706.0+1 from rhvh-4.
2. After reboot directory "/var/log/ovirt-imageio-daemon/" is still with root ownership:
# ls -ld /var/log/ovirt-imageio-daemon/
drwxr-xr-x. 2 root root 4096 Nov 20  2016 /var/log/ovirt-imageio-daemon/
3. 

Actual results:
ovirt-imageio-daemon.service fails to start.

Expected results:
ovirt-imageio-daemon.service should start.

Additional info:
No issue with fresh installation.
Comment 3 Huijuan Zhao 2017-08-04 05:01:49 EDT
QE can reproduce this issue.


Test version:
From: rhvh-4.0-20170307.1
To:   rhvh-4.1-20170706.0
      imgbased-0.9.33-0.1.el7ev.noarch

# imgbase layout
rhvh-4.0-0.20170307.0
 +- rhvh-4.0-0.20170307.0+1
rhvh-4.1-0.20170706.0
 +- rhvh-4.1-0.20170706.0+1


Test steps:
1. Install rhvh-4.0-20170307.1
2. Login rhvh, check /var/log/ovirt-imageio-daemon/ and ovirt-imageio-daemon.service:
2.1
# ls -ld /var/log/ovirt-imageio-daemon/
drwxr-xr-x. 2 root root 4096 Nov 20  2016 /var/log/ovirt-imageio-daemon/
2.2
ovirt-imageio-daemon.service fails to start.
3. Upgrade rhvh to rhvh-4.1-20170706.0
   # yum install redhat-virtualization-host-image-update-4.1-20170706.0.el7_3.noarch.rpm
4. Reboot and login new layer rhvh-4.1-20170706.0, check /var/log/ovirt-imageio-daemon/ and ovirt-imageio-daemon.service


Actual results:
1. After step 4, 
1.1
directory "/var/log/ovirt-imageio-daemon/" is still with root ownership.
# ls -ld /var/log/ovirt-imageio-daemon/
drwxr-xr-x. 2 root root 4096 Nov 20  2016 /var/log/ovirt-imageio-daemon/
1.2
ovirt-imageio-daemon.service fails to start.
# systemctl start ovirt-imageio-daemon.service
Job for ovirt-imageio-daemon.service failed because the control process exited with error code. See "systemctl status ovirt-imageio-daemon.service" and "journalctl -xe" for details.
# systemctl status ovirt-imageio-daemon.service
● ovirt-imageio-daemon.service - oVirt ImageIO Daemon
   Loaded: loaded (/usr/lib/systemd/system/ovirt-imageio-daemon.service; enabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Fri 2017-08-04 08:12:29 GMT; 35min ago
  Process: 1910 ExecStart=/usr/bin/ovirt-imageio-daemon (code=exited, status=1/FAILURE)
 Main PID: 1910 (code=exited, status=1/FAILURE)


Expected results:
1. After step 4, directory "/var/log/ovirt-imageio-daemon/" is not root ownership. Can start ovirt-imageio-daemon.service successful.


Additional info:
If refresh install rhvh-4.1-20170706, can start ovirt-imageio-daemon.service successful.
Comment 4 Ryan Barry 2017-08-08 22:33:27 EDT
Note that this was retargeted because QE identified it as a blocker in 4.0->4.1 upgrade flows yesterday while testing another bug, since the host will not come up in the engine of ovirt-imageio-daemon does not start
Comment 6 Huijuan Zhao 2017-08-10 02:38:38 EDT
Test version:
From: rhvh-4.0-20170307.1
To:   rhvh-4.1-20170808.0
      imgbased-0.9.41-0.1.el7ev.noarch

# imgbase layout
rhvh-4.0-0.20170307.0
 +- rhvh-4.0-0.20170307.0+1
rhvh-4.1-0.20170808.0
 +- rhvh-4.1-0.20170808.0+1


Test steps:
1. Install rhvh-4.0-20170307.1
2. Login rhvh, check /var/log/ovirt-imageio-daemon/ and ovirt-imageio-daemon.service:
2.1
# ls -ld /var/log/ovirt-imageio-daemon/
drwxr-xr-x. 2 root root 4096 Nov 20  2016 /var/log/ovirt-imageio-daemon/
2.2
ovirt-imageio-daemon.service fails to start.
3. Upgrade rhvh to rhvh-4.1-20170808.0
   # yum install redhat-virtualization-host-image-update-4.1-20170808.0.el7_4.noarch.rpm
4. Reboot and login new layer rhvh-4.1-20170808.0, check /var/log/ovirt-imageio-daemon/ and ovirt-imageio-daemon.service


Test results:
After step 4, directory "/var/log/ovirt-imageio-daemon/" is not root ownership. Can start ovirt-imageio-daemon.service successful.
# ls -ld /var/log/ovirt-imageio-daemon/
drwxr-xr-x. 2 vdsm kvm 4096 Aug  9 03:21 /var/log/ovirt-imageio-daemon/


Additional info:
Refresh install rhvh-4.1-0.20170808.0, also can start ovirt-imageio-daemon.service successful.


So this bug is fixed in imgbased-0.9.41-0.1.el7ev.noarch, change the status to VERIFIED.
Comment 8 errata-xmlrpc 2017-08-10 12:11:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2464

Note You need to log in before you can comment on or make changes to this bug.