Bug 147610 - netfs doesn't properly unmount _netdev devices
netfs doesn't properly unmount _netdev devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 132991 137160 144781
  Show dependency treegraph
 
Reported: 2005-02-09 14:53 EST by AJ Lewis
Modified: 2014-03-16 22:52 EDT (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2005-124
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 11:36:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix where netfs looks for _netdev info (1.53 KB, patch)
2005-02-09 15:05 EST, AJ Lewis
no flags Details | Diff

  None (edit)
Description AJ Lewis 2005-02-09 14:53:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
'service netfs stop' does not unmount filesystems that have the _netdev option in /etc/fstab.  Calling 'umount -a -O _netdev' (which is in netfs for _netdev devices) manually will unmount said filesystems.  It appears that the problem is in how netfs detects which devices have the _netdev flag.   It currently looks in /proc/mounts, but /proc/mounts does not list the _netdev flag.  _netdev only shows up in /etc/mtab and the 'mount' command output.

Version-Release number of selected component (if applicable):
initscripts-7.31.18.EL-1

How reproducible:
Always

Steps to Reproduce:
1. Add a line to /etc/fstab for a filesystem, and add the _netdev option
/dev/sdd        /mnt    auto    _netdev 0       0

2. mount the filesystem
# mount /mnt
3. run 'service netfs stop'
  

Actual Results:  /dev/sdd is still mounted on /mnt

Expected Results:  /dev/sdd should have been unmounted

Additional info:

_netdev is recommended by the iscsi-initiator-utils README as a method to mount and unmount iscsi devices.  Currently when people use this method, their filesystems do not get unmounted, and the system crashes during the reboot process.  (See bug #144781 for more information)  Even without the crash, this could cause filesystem corruption since it is not cleanly unmounted before the network is shut off.
Comment 1 AJ Lewis 2005-02-09 15:05:50 EST
Created attachment 110890 [details]
Fix where netfs looks for _netdev info

Change netfs so it looks at /etc/mtab instead of /proc/mounts for the _netdev
flag
Comment 2 Tom Coughlan 2005-02-09 15:26:06 EST
This is creating serious heartburn for iSCSI users in RHEL 3. Will it be
possible to get the fix in U5?  Thanks.
Comment 3 Bill Nottingham 2005-02-09 15:49:22 EST
Fixed in 7.31.22.EL-1/7.93.13.EL-1.
Comment 4 Bill Nottingham 2005-02-15 12:44:59 EST
*** Bug 148764 has been marked as a duplicate of this bug. ***
Comment 5 Jay Turner 2005-04-16 06:35:34 EDT
U1 fix confirmed in 7.93.13.EL-1, U5 fix confirmed in 7.31.22.EL-1.  Moving to
PROD_READY.
Comment 6 Tim Powers 2005-05-18 11:36:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-123.html

Note You need to log in before you can comment on or make changes to this bug.