Bug 1476149 - [distgit] indefinitely enlarging .gitignore file (don't append src.rpm files)
[distgit] indefinitely enlarging .gitignore file (don't append src.rpm files)
Status: CLOSED NOTABUG
Product: Copr
Classification: Community
Component: backend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-28 03:01 EDT by Pavel Raiskup
Modified: 2018-04-06 11:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-06 11:30:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Raiskup 2017-07-28 03:01:31 EDT
See the lines:

  /postgresql-9.6.3-9.src.rpm
  /sclo-postgresql96-postgresql-9.6.3-0.1.src.rpm

in:

  http://copr-dist-git.fedorainfracloud.org/cgit/@db-sig/sclo-postgresql96/postgresql.git/commit/?id=08f680b3923d5b7abe8efe41fb54d76b809af049

Putting the srpm there makes the gitignore larger with each package rebuild.

Also note the rpkg issue:
https://pagure.io/rpkg/issue/233
Comment 1 Pavel Raiskup 2017-07-28 03:13:36 EDT
Ah, I misread the 08f680b patch - it is actually removing the old srpm
file, which is not that bad (probably).

It is not common to put src.rpm into .gitignore file though (useless) --
the generated src.rpm differs at least %dist tag.
Comment 2 clime 2018-04-06 11:14:17 EDT
I think this can be closed then? This seems to be an rpkg issue anyway.
Comment 3 Pavel Raiskup 2018-04-06 11:30:15 EDT
ack

Note You need to log in before you can comment on or make changes to this bug.